Kith and Kin Pro manual

Kith and Kin Pro site SpanSoft main site

Kith and Kin Pro

Getting started

Introducing Kith and Kin Pro

Converting from older versions of Kith and Kin

Using Kith and KinPro with TreeDraw

Tutorials

Tutorial - Using the Tree Area

Tutorial - Working with person and family data forms

Tutorial - Simple searching

Tutorial - Searching using queries

Tutorial - Printing

Tutorial - Adding extra fields to people and families

Tutorial - Starting your own family tree

Tutorial - Importing a GEDCOM file

Tasks

Database maintenance

Starting a new database

Creating a clean database

Opening an existing database

Saving a database

Merging two databases

Copying a database

Copying part of a database

Changing the name of a database

Packing a database

Repairing a database

Clearing a database

Deleting a database

Adding and maintaining user-defined fields

Backing-up your data

Restoring data from a backup

Data maintenance

Adding a new family

Adding a new person

Editing an existing family

Editing an existing person

Marking probable links

Adding and maintaining aliases

Editing notes

Organising notes

Entering dates

Working with pictures

Working with objects

Adding and maintaining sources

Deleting a family

Deleting a person

Adding and maintaining source documents

Adding and maintaining source document repositories

Updating descriptions

Re-using an old person or family code

Updating death flags

Removing duplicate records

Editing data in bulk

Searching / querying

Searching for people

Seaching for families

Searching for sources

Using a query to find data

Calculating ages

Calculating phonetic codes

Displaying statistics

Displaying a relationship between two people

Searching for date errors / inconsistencies

Searching for events on a particular day

Searching for people who are not on the Tree Area

Displaying modified records

Screen

Moving around the Tree Area

Zooming in and out

Moving to a specific family

Selecting families using the mouse

Selecting families by relationship

Selecting all families

Moving families

Displaying a family summary

Arranging the open forms

Closing all open forms at once

Aligning families vertically

Using the Timeline Window

Choosing layers

Choosing the selection's layer

Choosing all layers

Moving families to a layer

Removing families from a layer

Creating a new layer from selection

Managing layers

Choosing fonts and colours

Turning the Tree Area on and off

Turning the Button Bar on and off

Turning the Status Bar on and off

Turning the Tree Area Control on and off

Printing

Using the report control form

Printing the tree layout

Printing family details

Printing person details

Printing indices

Printing a descendant tree

Printing an ancestral tree

Printing an indented descendant tree

Printing a missing data report

Printing a timeline

Printing a census report

Printing source document details

Printing document repository details

Setting printer options

Setting page options

Previewing a report on the screen

Printing from a preview

Printing to text files

Copying printed pages to the clipboard

Importing / exporting

Importing a GEDCOM file

Exporting a GEDCOM file

Exporting Web pages

Customising Web pages

Exporting data to a delimited text file

Importing a text file into notes

Exporting a text file from notes

Exporting a report to a PDF file

General

Setting preferences

Editing the timeline

Customising the button bar

Setting date options

Converting dates

Setting options

Setting current database options

Choosing a family to move to when the tree is opened

Choosing the current database language

Setting regional / language options

Setting picture options

Exiting from the program

Checking for program updates

Reference

File menu

Edit menu

Search menu

View menu

Layers menu

Tools menu

Window menu

Options menu

Using the Tree Area Control

Selecting / defining a database name

Selecting a family

Selecting a person

Database fields

Additional LDS information

SQL syntax

Supported GEDCOM syntax

Timeline text file format

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

GEDCOM

Layer

LDS

Metaphone

OLE embedding

OLE linking

OLE object

Soundex

Tree Area

How to get support

How to contact us

Ordering / registration

Exporting Web pages

One of the major advantages of the Internet for family history researchers has been the opportunity to post your own genealogy information onto the Web so that it is instantly available to people all over the world.

Kith and Kin Pro designs and produces your own Web pages and packs them into files ready for uploading to your Web site. All you have to provide is a link from your homepage to the genealogy start page which the program has produced. The start page is always called GENSTART.HTM. Most Web page publishing programs will let you add a link to this page easily. If you write your own Web pages using a text editor, a typical link to the genealogy start page might look like this:

<a href="genstart.htm">My Family Tree</a>

Some of the Web pages produced by Kith and Kin Pro include a surname index. The alphabetic order of surnames is defined by the alphabet in the currently loaded regional file. For non-English Western European languages, you can select or define your own alphabet, eg. the Swedish alphabet is ABCDEFGHIJKLMNOPQRSTUVWXYZÅÄÖ

You can view the Web pages on your computer before you upload them by using your Web browser program. For example in Microsoft Internet Explorer use "File | Open" from the main menu and browse to the GENSTART.HTM file.

The following options are available for exporting Web pages.


Families:

All:

Set this option to export all people and families from the current family tree database.

Selection:

Export only the currently highlighted families and the people who appear in them by setting this option.

Range:

Enter a "From" and "To" family code. All families with codes between these values and their related people will be exported.


Web page appearance:

Start page title:

Enter the text which will appear as a title on the genealogy start page.

Start page notes:

Enter any additional notes which should appear on the genealogy start page.

E-mail:

Optionally, enter your e-mail address. This will appear on the genealogy start page and visitors to your Web site will be able to click on the address to send e-mail direct to you.

Global header:

Optionally, enter text that you want to appear at the top of every Web page. This can include HTML code if you wish.

Global footer:

Optionally, enter text that you want to appear at the bottom of every Web page. This can include HTML code if you wish.

Global header/footer on start page:

If you have entered global header or footer text, the text will appear on every Web page except the genealogy start page. Select this option to include the header/footer text on the genealogy start page as well.

Return icon return.gif:

"Return.gif" is a graphic file which will be used as the "return to start" icon at the foot of every Web page. Kith and Kin Pro is supplied with several suitable icons in the "Web Source" folder or you can provide your own graphic. Copy the graphic file you want to use into the "\no_erase" folder and rename it to "return.gif" (see Customising Web pages). If you do not want to include a return icon simply clear this option.

Online URL:

Only required if you are also exporting a Tree Layout PDF file as part of the Web pages. You must provide here the absolute URL of the folder where the Web pages will be stored online. For example, if you are uploading the exported Web pages to your own website where the URL of the start page is www.mywebsite.org.uk/familypages/genstart.htm, you should enter the URL http://www.mywebsite.org.uk/familypages. The online URL must begin with either http:// or https://.


Pictures:

Include pictures:

Any pictures associated with people or families will be included if they have their "Include image in printouts" option set. Pictures for Web pages are saved as JPEG files to save space, unless they contain any transparency. If a picture file contains any transparency (usually a GIF or PNG) then the picture is stored as a PNG file for Web output to preserve the transparency.

Link to big pictures:

Use this option to include the full-sized pictures on the Web. Visitors to your site can click on the thumbnail images in the family tree data to view the full-sized pictures.

Include gallery page:

Kith and Kin Pro can automatically produce a picture gallery page containing copies of all the pictures used elsewhere in the family tree data. A link to the gallery page is included in GENSTART.HTM. The "Link to big pictures" option will affect the gallery page as well.

Thumbnails size (pixels):

The maximum height or width of picture thumbnails.

Thumbnails across:

The maximum number of picture thumbnails in a row across a Web page.

Max big picture size (pixels):

The maximum height or width of full-sized pictures.

JPEG quality:

You can choose the JPEG picture quality (ie. the inverse of the amount of compression). Higher quality pictures create larger files; 50% is usually a good compromise.


Data:

P/F codes:

Include the person and family codes in the Web pages.

Dates:

Include person and family dates, birth, marriage, etc.

Places:

Include places associated with person and family dates, eg. Death place.

User fields:

Include any user-defined fields for people and families. Some data may be excluded by the privacy level setting.

Sex:

The program will put "{M}" after male names and "{F}" after female names.

Aliases:

Include aliases. If set, this option also puts each alias into the surname index so that you can find the person using any of their names.

Notes:

Set this option if you want person and family notes included in the Web pages. Some data may be excluded by the privacy level setting.

Sources:

Set this option if you want source references, source documents and source repositories included in the Web pages. Only documents and repositories which are referenced by the exported people/families will be included.

Child surnames:

Include surnames for children on their family page. Normally this is not required since the surnames can be assumed to be the same as the father's.

Details in index:

Set this option to include dates and places (if the "Places" option is set) in the surname list.

Tree Layout PDF:

Set this option to include a PDF file similar to the Tree Area display on the screen. The PDF file will open in the user's browser and clicking on a family rectangle will navigate to the appropriate family details page. Due to limitations in the Adobe PDF Reader, this feature only works with Web pages you have uploaded to the Internet. See also: "Online URL".

Timeline:

Set this option to include a timeline similar to the one in the Timeline window. Events from the default timeline will be included if the "Historical events" option is set in the Customise timeline dialog.

Indicate probable:

Include the word "Probable" for probable links.

Privacy level

Set the cutoff privacy level for notes and user-defined fields. Notes and fields with a privacy level above the one you set here will be ignored. For example, enter level 2 to include notes/fields with privacy levels 0, 1 and 2. A level 3 or 4 note or field would be excluded.

Keep births private:

Set this option to exclude birth/christening dates of people who are still alive, ie. their "Dead" flag is set to false.

Hide living people:

Set this option to exclude all data from people who are still alive, ie. their "Dead" flag is set to false. Their names will be replaced with: "(Living person hidden)".


Create Web files in this folder:

You must select a folder on your hard drive where Kith and Kin Pro will create all the Web page files. If the folder does not exist the program will create it. Click on the Browse button to select or create an appropriate folder.

Clear folder before exporting:

If you are re-building your Web pages it is normal to have any existing files deleted from the output folder before the new ones are created. That way you know that all the files in the output folder are new and must be uploaded. If you want to simply overwrite the existing files and leave any other files intact, turn this option off.

Note that the special output folder "no_erase" will not be deleted by this function. This folder contains the icons and CSS stylesheet for your Web pages and you may wish to customise them. This allows you to re-export the Web pages to the same folder without losing any changes you may have made to the stylesheet.

Create index.htm pages in subfolders:

Select this option to have Kith and Kin Pro automatically add to each output subfolder a simple index.htm file which redirects visitors to your GENSTART.HTM page. This is a security feature which prevents visitors from inadvertantly seeing all the files in the subfolder.

The index.htm file is copied from the "Web source" folder and contains:
"Page invalid" - Please click here to go to the genealogy page.

See also