Kith and Kin Pro manual

Kith and Kin Pro site SpanSoft main site

Kith and Kin Pro

Getting started

Introducing Kith and Kin Pro

Converting from older versions of Kith and Kin

Using Kith and KinPro with TreeDraw

Tutorials

Tutorial - Using the Tree Area

Tutorial - Working with person and family data forms

Tutorial - Simple searching

Tutorial - Searching using queries

Tutorial - Printing

Tutorial - Adding extra fields to people and families

Tutorial - Starting your own family tree

Tutorial - Importing a GEDCOM file

Tasks

Database maintenance

Starting a new database

Creating a clean database

Opening an existing database

Saving a database

Merging two databases

Copying a database

Copying part of a database

Changing the name of a database

Packing a database

Repairing a database

Clearing a database

Deleting a database

Adding and maintaining user-defined fields

Backing-up your data

Restoring data from a backup

Data maintenance

Adding a new family

Adding a new person

Editing an existing family

Editing an existing person

Marking probable links

Adding and maintaining aliases

Editing notes

Organising notes

Entering dates

Working with pictures

Working with objects

Adding and maintaining sources

Deleting a family

Deleting a person

Adding and maintaining source documents

Adding and maintaining source document repositories

Updating descriptions

Re-using an old person or family code

Updating death flags

Removing duplicate records

Editing data in bulk

Searching / querying

Searching for people

Seaching for families

Searching for sources

Using a query to find data

Calculating ages

Calculating phonetic codes

Displaying statistics

Displaying a relationship between two people

Searching for date errors / inconsistencies

Searching for events on a particular day

Searching for people who are not on the Tree Area

Displaying modified records

Screen

Moving around the Tree Area

Zooming in and out

Moving to a specific family

Selecting families using the mouse

Selecting families by relationship

Selecting all families

Moving families

Displaying a family summary

Arranging the open forms

Closing all open forms at once

Aligning families vertically

Using the Timeline Window

Choosing layers

Choosing the selection's layer

Choosing all layers

Moving families to a layer

Removing families from a layer

Creating a new layer from selection

Managing layers

Choosing fonts and colours

Turning the Tree Area on and off

Turning the Button Bar on and off

Turning the Status Bar on and off

Turning the Tree Area Control on and off

Printing

Using the report control form

Printing the tree layout

Printing family details

Printing person details

Printing indices

Printing a descendant tree

Printing an ancestral tree

Printing an indented descendant tree

Printing a missing data report

Printing a timeline

Printing a census report

Printing source document details

Printing document repository details

Setting printer options

Setting page options

Previewing a report on the screen

Printing from a preview

Printing to text files

Copying printed pages to the clipboard

Importing / exporting

Importing a GEDCOM file

Exporting a GEDCOM file

Exporting Web pages

Customising Web pages

Exporting data to a delimited text file

Importing a text file into notes

Exporting a text file from notes

Exporting a report to a PDF file

General

Setting preferences

Editing the timeline

Customising the button bar

Setting date options

Converting dates

Setting options

Setting current database options

Choosing a family to move to when the tree is opened

Choosing the current database language

Setting regional / language options

Setting picture options

Exiting from the program

Checking for program updates

Reference

File menu

Edit menu

Search menu

View menu

Layers menu

Tools menu

Window menu

Options menu

Using the Tree Area Control

Selecting / defining a database name

Selecting a family

Selecting a person

Database fields

Additional LDS information

SQL syntax

Supported GEDCOM syntax

Timeline text file format

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

GEDCOM

Layer

LDS

Metaphone

OLE embedding

OLE linking

OLE object

Soundex

Tree Area

How to get support

How to contact us

Ordering / registration

Version information

This is a list of new features, enhancements and bug fixes which is updated with the release of each new version of Kith and Kin Pro.

Version 3.2.2 Feb 2014

Bug-fix release

Fixes SQL query errors when using a previous query which split field names over two lines.

Version 3.2.1 Mar 2013

Bug-fix release

Prevents a blank regional string for "Surnames beginning with (none)".

Clearing the database root folder box when selecting a database caused an error.

Version 3.2.0 Mar 2012

Minor upgrade

Web page exporting can now include the Tree Layout as a hotlinked PDF file.

Using "File | Import from file" in the notes editor now displays a warning.

Using "Edit | Select families" could result in multiple selections of the same family rectangle.

Fixed the corrupted display in the layers box of the status bar.

Version 3.1.3 Aug 2011

Bug-fix release

Prevents database names with leading/trailing spaces.

Version 3.1.2 Feb 2011

Bug-fix release

Fixes the "List index out of bounds" error when exporting a GEDCOM file.

Version 3.1.1 Feb 2011

Bug-fix release

"Visit Web site" button added to repository in sources form.

Several problems fixed in Family/Source/SQL querying.

GEDCOM export did not include a source where births/deaths/marriages had date but no place data. Fixed.

Printed Tree Layout formatting fixed when including only surnames and dates.

Web Export - improved indexing of surnames. Now regional language dependant.

Version 3.1.0 May 2010

Minor upgrade

Instant backup feature added.

Option to scroll Tree Area to selected layer added.

New Background Layer displays families not on any other layer.

"Right-click | Switch to layer" on families in Person Data form added.

Upload database to SpanSoft Support feature added.

Layer selection window is now sizeable.

Select Source Document list did not show Repository's Ref data. Fixed.

Database conversion utility failed if no BDE installed. Fixed.

Changing "Options | Preferences | Options | Text file delimiter" required a restart. Fixed.

Version 3.0.7 March 2010

Bug-fix release

Person and family selection lists now retain the selected record.

Improved the appearance of some dialogs on systems using non-standard DPI settings.

The "Cascade" function now starts aligning open forms at the top-left of the Tree Area.

Opening some pictures from the search results list did not set the width and height fields correctly. Fixed.

The file date in exported GEDCOM headers now conforms to GEDCOM format.

Dropping a file onto the Kith and Kin Pro icon removed the name of the last-used database. Fixed.

Version 3.0.6 October 2009

Bug-fix release

Improved the appearance of some dialogs on systems using "Large fonts" (DPI setting).

Importing a text file into Customise Timeline ignored the last line. Fixed.

Up-to-date timelines for Australia, Canada, New Zealand, UK and USA included.

Version 3.0.5 September 2009

Bug-fix release

Adding or editing a parent did not correctly redraw their spouse's link line in the Tree Area. Fixed.

Adding more than one object to a person or family caused a "Duplicate key" error. Fixed.

Database engine update to V4.28 build 6.

Version 3.0.4 July 2009

Bug-fix release

Database | Merge. Source references from the incoming database were not linked to the correct records. Fixed.

Version 3.0.3 June 2009

Bug-fix release

Web pages export. Some thumbnail descriptions were truncated in the gallery page. Fixed.

PDF file export. The font changed when text crossed page breaks. Fixed.

V3 Database Conversion utility displayed a "Timestamp error" when converting databases with invalid data. Fixed.

Version 3.0.2 June 2009

Bug-fix release

Tab labels not showing under Vista 64-bit. Fixed.

Change dates were not shown in "Tools | Records modified". Fixed.

Problems displaying some windows on multiple-monitor systems fixed.

Version 3.0.1 May 2009

Bug-fix release

Added scroll bar to all multi-line text edit boxes (person/family/source/document/repository).

Changed the default timeline import file type from .tml to .txt

Fixed potential freezing of some "File | Database | Merge" operations.

Fixed the Help button in PDF export dialog.

Changing the contents of a multi-line text edit box and then opening the Notes Editor did not preserve the changes. Fixed.

"Tools | Show relationship" gave the error "Field 'Description' not found". Fixed.

Conversion utility - added error logging.

Conversion utility - fixed "Invalid database" error on Vista PCs.

Version 3.0.0 May 2009

First release

Changes between version 2 and version 3

Download genealogy software with free 30-day trial. Free to try software is for genealogy and family history. Import GEDCOM files and print genealogy charts using our free to try family history program. Download our free to try family tree program. Free 30-day trial family history program. Historians can download genealogy database program which is free-to-try. Download genealogy program to store your family tree, there is a free trial. Download genealogy software. You can download free trial versions of our family tree software to store your family history. To store family history, download genealogy software. Download family history software which is free to try and is used for genealogy. Store your family tree in our genealogy software database. Store family trees using our free to try family tree program. Download genealogy program which is free to try. Download genealogy software for family history. Why not download genealogy software for your ancestors history. It's free for 30 days. We specialize in free to try genealogy software available for download. Here users can download family tree software for historians. Download genealogy software for family history research. Our database program is the best for family history research and tracing your ancestors.