Kith and Kin Pro manual

Kith and Kin Pro site SpanSoft main site

Kith and Kin Pro

Getting started

Introducing Kith and Kin Pro

Converting from older versions of Kith and Kin

Using Kith and KinPro with TreeDraw

Tutorials

Tutorial - Using the Tree Area

Tutorial - Working with person and family data forms

Tutorial - Simple searching

Tutorial - Searching using queries

Tutorial - Printing

Tutorial - Adding extra fields to people and families

Tutorial - Starting your own family tree

Tutorial - Importing a GEDCOM file

Tasks

Database maintenance

Starting a new database

Creating a clean database

Opening an existing database

Saving a database

Merging two databases

Copying a database

Copying part of a database

Changing the name of a database

Packing a database

Repairing a database

Clearing a database

Deleting a database

Adding and maintaining user-defined fields

Backing-up your data

Restoring data from a backup

Data maintenance

Adding a new family

Adding a new person

Editing an existing family

Editing an existing person

Marking probable links

Adding and maintaining aliases

Editing notes

Organising notes

Entering dates

Working with pictures

Working with objects

Adding and maintaining sources

Deleting a family

Deleting a person

Adding and maintaining source documents

Adding and maintaining source document repositories

Updating descriptions

Re-using an old person or family code

Updating death flags

Removing duplicate records

Editing data in bulk

Searching / querying

Searching for people

Seaching for families

Searching for sources

Using a query to find data

Calculating ages

Calculating phonetic codes

Displaying statistics

Displaying a relationship between two people

Searching for date errors / inconsistencies

Searching for events on a particular day

Searching for people who are not on the Tree Area

Displaying modified records

Screen

Moving around the Tree Area

Zooming in and out

Moving to a specific family

Selecting families using the mouse

Selecting families by relationship

Selecting all families

Moving families

Displaying a family summary

Arranging the open forms

Closing all open forms at once

Aligning families vertically

Using the Timeline Window

Choosing layers

Choosing the selection's layer

Choosing all layers

Moving families to a layer

Removing families from a layer

Creating a new layer from selection

Managing layers

Choosing fonts and colours

Turning the Tree Area on and off

Turning the Button Bar on and off

Turning the Status Bar on and off

Turning the Tree Area Control on and off

Printing

Using the report control form

Printing the tree layout

Printing family details

Printing person details

Printing indices

Printing a descendant tree

Printing an ancestral tree

Printing an indented descendant tree

Printing a missing data report

Printing a timeline

Printing a census report

Printing source document details

Printing document repository details

Setting printer options

Setting page options

Previewing a report on the screen

Printing from a preview

Printing to text files

Copying printed pages to the clipboard

Importing / exporting

Importing a GEDCOM file

Exporting a GEDCOM file

Exporting Web pages

Customising Web pages

Exporting data to a delimited text file

Importing a text file into notes

Exporting a text file from notes

Exporting a report to a PDF file

General

Setting preferences

Editing the timeline

Customising the button bar

Setting date options

Converting dates

Setting options

Setting current database options

Choosing a family to move to when the tree is opened

Choosing the current database language

Setting regional / language options

Setting picture options

Exiting from the program

Checking for program updates

Reference

File menu

Edit menu

Search menu

View menu

Layers menu

Tools menu

Window menu

Options menu

Using the Tree Area Control

Selecting / defining a database name

Selecting a family

Selecting a person

Database fields

Additional LDS information

SQL syntax

Supported GEDCOM syntax

Timeline text file format

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

GEDCOM

Layer

LDS

Metaphone

OLE embedding

OLE linking

OLE object

Soundex

Tree Area

How to get support

How to contact us

Ordering / registration

Tutorial - Simple searching

This tutorial requires the sample database supplied with the program - use "File | Database | Open | Sample_V3"

Subject: Using simple searches to find people, families or sources.

In this tutorial we will be doing some simple searches. For advanced SQL queries see: Using a query to find data.

Click on the "Search" button on the button bar to open the search window.

You can choose whether you want to search for people, families or sources by clicking on the appropriate tab at the top of the window. Click on the "Person" tab for now.

Click on the "Clear person criteria" button to make sure that there is nothing in the search criteria. Also, make sure that the "Partial match" option is selected, "Case sensitive" is clear and "Match all fields" is selected.

Click on the "Surname" field and type in "gordon" (without the quotes). Now click on the "Search" button . 38 records will be displayed in the search results list - all the people in the database with the surname "Gordon".

Now we can narrow down our search - say we want to find only males with the surname "Gordon". Click on the "Male" field. Notice that a drop-down button appears to the right of the Male field. This is because there are only three possible values to enter in here - "True" (male), "False" (female) or blank (don't care). Click on the drop-down button and select "True". Now click on the "Search" button again. This time only 21 records are displayed.

Let's see how we can use Kith and Kin Pro's Metaphone and Soundex fields to search for similar sounding surnames. Click on the "Clear" button and then type "white" into the "Surname" field. Clicking on "Search" displays 3 people. Now select the "Metaphone" option and click "Search" again. An extra person is displayed, Jean WHYTE. WHITE and WHYTE sound similar and so have the same Metaphone code (the actual Metaphone code for WHITE is WT which you can verify in the Phonetics Calculator).

Carrying out narrower searches is simply a matter of entering more data into the search fields. For instance, if you wanted to look for all women who were born in Glasgow between 1800 and 1899, your search fields would look like: Male = False, Birth date = 1800..1899, Birth place = Glasgow.

Notice in that last example that we used a date range. Dates can be entered as exact, partial or a range (using ".." to denote a range). For example:

There are four important options just to the left of the "Search" button which are common to all types of search.
Criteria for text-type fields can be partial matches and/or case-sensitive.
For example, a partial match and not case-sensitive search for "Firstnames = ann" will find "Ann", "Anne" and "Jeanne" but with partial match turned off will only find "Ann".
If the same example was a partial match but case-sensitive then only "Firstnames = Ann" would find "Ann" and "Anne". Case-sensitive searches match the exact upper and lower case letters in the search fields.
Normally, searches with multiple conditions (more than one field filled out) produce results where records meet every condition. You can change this so that the results contain records which meet any of the conditions by clicking on the Match any field option. Clicking on the Match all fields option only finds records which match all the conditions.

Once you have records in the results list, you can do things with them. Double-clicking on a record opens its data form for editing. Right-clicking on the results list pops up a menu which allows you to print or preview the results list or export the records to a delimited text file.

A delimited text file is useful for exporting data from Kith and Kin Pro to other applications such as a database or spreadsheet program. Once the data is in a database, for instance, you can produce customised list reports.

You can change the width of the columns in the results list by dragging the right edge of the column in the top row (where the column names are) left or right. You can also change the order of the columns by dragging the middle of the column in the top row left or right.

Searching for families and sources works in exactly the same way. Just click on the appropriate tab at the top of the Search Window.

Click on the "Close" button to close the search window.

Next tutorial - Searching using queries

Download family history software with free 30-day trial. Our free to try software is for family history research and family trees. We specialize in free to try genealogy program available for download. Here users can download genealogy program for historians. Download genealogy software for family history. Why not download genealogy software for your ancestors history? It's free for 30 days. Free 30-day trial family history software. Users can download genealogy database program which is free-to-try. Download genealogy program to store your family tree, there is a free trial. Download genealogy software. You can download free trial versions of our genealogy program to store your family history. To store family history, download genealogy software. Import GEDCOM files and print family tree charts using our free to try genealogy software. Download our free to try program for researching your ancestors. Download family history software which is free to try and is used for ancestry research. Store your family tree in our genealogy software database. Store family trees using our free to try database program. Download family history program which is free to try. Download genealogy software for family history research. Our family history program is good for family history research.