Kith and Kin Pro manual

Kith and Kin Pro site SpanSoft main site

Kith and Kin Pro

Getting started

Introducing Kith and Kin Pro

Converting from older versions of Kith and Kin

Using Kith and KinPro with TreeDraw

Tutorials

Tutorial - Using the Tree Area

Tutorial - Working with person and family data forms

Tutorial - Simple searching

Tutorial - Searching using queries

Tutorial - Printing

Tutorial - Adding extra fields to people and families

Tutorial - Starting your own family tree

Tutorial - Importing a GEDCOM file

Tasks

Database maintenance

Starting a new database

Creating a clean database

Opening an existing database

Saving a database

Merging two databases

Copying a database

Copying part of a database

Changing the name of a database

Packing a database

Repairing a database

Clearing a database

Deleting a database

Adding and maintaining user-defined fields

Backing-up your data

Restoring data from a backup

Data maintenance

Adding a new family

Adding a new person

Editing an existing family

Editing an existing person

Marking probable links

Adding and maintaining aliases

Editing notes

Organising notes

Entering dates

Working with pictures

Working with objects

Adding and maintaining sources

Deleting a family

Deleting a person

Adding and maintaining source documents

Adding and maintaining source document repositories

Updating descriptions

Re-using an old person or family code

Updating death flags

Removing duplicate records

Editing data in bulk

Searching / querying

Searching for people

Seaching for families

Searching for sources

Using a query to find data

Calculating ages

Calculating phonetic codes

Displaying statistics

Displaying a relationship between two people

Searching for date errors / inconsistencies

Searching for events on a particular day

Searching for people who are not on the Tree Area

Displaying modified records

Screen

Moving around the Tree Area

Zooming in and out

Moving to a specific family

Selecting families using the mouse

Selecting families by relationship

Selecting all families

Moving families

Displaying a family summary

Arranging the open forms

Closing all open forms at once

Aligning families vertically

Using the Timeline Window

Choosing layers

Choosing the selection's layer

Choosing all layers

Moving families to a layer

Removing families from a layer

Creating a new layer from selection

Managing layers

Choosing fonts and colours

Turning the Tree Area on and off

Turning the Button Bar on and off

Turning the Status Bar on and off

Turning the Tree Area Control on and off

Printing

Using the report control form

Printing the tree layout

Printing family details

Printing person details

Printing indices

Printing a descendant tree

Printing an ancestral tree

Printing an indented descendant tree

Printing a missing data report

Printing a timeline

Printing a census report

Printing source document details

Printing document repository details

Setting printer options

Setting page options

Previewing a report on the screen

Printing from a preview

Printing to text files

Copying printed pages to the clipboard

Importing / exporting

Importing a GEDCOM file

Exporting a GEDCOM file

Exporting Web pages

Customising Web pages

Exporting data to a delimited text file

Importing a text file into notes

Exporting a text file from notes

Exporting a report to a PDF file

General

Setting preferences

Editing the timeline

Customising the button bar

Setting date options

Converting dates

Setting options

Setting current database options

Choosing a family to move to when the tree is opened

Choosing the current database language

Setting regional / language options

Setting picture options

Exiting from the program

Checking for program updates

Reference

File menu

Edit menu

Search menu

View menu

Layers menu

Tools menu

Window menu

Options menu

Using the Tree Area Control

Selecting / defining a database name

Selecting a family

Selecting a person

Database fields

Additional LDS information

SQL syntax

Supported GEDCOM syntax

Timeline text file format

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

GEDCOM

Layer

LDS

Metaphone

OLE embedding

OLE linking

OLE object

Soundex

Tree Area

How to get support

How to contact us

Ordering / registration

Editing notes

The Notes Editor allows you to edit, copy, print, import and export text. You can also edit notes directly in a person or family data form.

The text area of the Notes Editor works just like any Windows text editor. You can use the usual hot-keys, mouse buttons and menu commands. The text is not formatted but you can choose the font used in Preferences. Lines should not be broken with RETURNs unless you want to start a new paragraph. Kith and Kin Pro will wrap the text as appropriate when printing reports.

Use File | Import from file to replace the all of the current notes with the contents of a text file. Note that this operation cannot be undo.

Searching for text:

Use Find from the Search menu. Enter the text you want to find in the "Find what" box. Set "Match whole word only" if the text you are looking for is a word rather than part of a word, eg. "fred" would not match "Alfred". Set "Match case" if you want the upper and lower case letters to match exactly, eg. "Fred" would match "Frederick" but not "Alfred". Click on the Find next button to perform the search. The text (if found) will be shown selected in the text area. Click on the "Find next" button again to find the next occurrence of the search text.

Replacing text:

Use Replace from the Search menu. Enter the text you want to find in the "Find what" box and the text to replace it with in the "Replace with" box. Set "Match whole word only" if the text you are looking for is a word rather than part of a word, eg. "fred" would not match "Alfred". Set "Match case" if you want the upper and lower case letters to match exactly, eg. "Fred" would match "Frederick" but not "Alfred". Click on the Find next button to find the first occurrence. The text (if found) will be shown selected in the text area. You can now click on the Replace button to replace just the selected text. Click on the "Find next" button again to find the next occurrence of the search text. Click on the Replace all button at any time to find and replace all occurrences of the search text.

Printing:

Use Print from the File menu. The text in the text area is printed using the same font as used on the screen.

See also