Kith and Kin Pro manual

Kith and Kin Pro site SpanSoft main site

Kith and Kin Pro

Getting started

Introducing Kith and Kin Pro

Converting from older versions of Kith and Kin

Using Kith and KinPro with TreeDraw

Tutorials

Tutorial - Using the Tree Area

Tutorial - Working with person and family data forms

Tutorial - Simple searching

Tutorial - Searching using queries

Tutorial - Printing

Tutorial - Adding extra fields to people and families

Tutorial - Starting your own family tree

Tutorial - Importing a GEDCOM file

Tasks

Database maintenance

Starting a new database

Creating a clean database

Opening an existing database

Saving a database

Merging two databases

Copying a database

Copying part of a database

Changing the name of a database

Packing a database

Repairing a database

Clearing a database

Deleting a database

Adding and maintaining user-defined fields

Backing-up your data

Restoring data from a backup

Data maintenance

Adding a new family

Adding a new person

Editing an existing family

Editing an existing person

Marking probable links

Adding and maintaining aliases

Editing notes

Organising notes

Entering dates

Working with pictures

Working with objects

Adding and maintaining sources

Deleting a family

Deleting a person

Adding and maintaining source documents

Adding and maintaining source document repositories

Updating descriptions

Re-using an old person or family code

Updating death flags

Removing duplicate records

Editing data in bulk

Searching / querying

Searching for people

Seaching for families

Searching for sources

Using a query to find data

Calculating ages

Calculating phonetic codes

Displaying statistics

Displaying a relationship between two people

Searching for date errors / inconsistencies

Searching for events on a particular day

Searching for people who are not on the Tree Area

Displaying modified records

Screen

Moving around the Tree Area

Zooming in and out

Moving to a specific family

Selecting families using the mouse

Selecting families by relationship

Selecting all families

Moving families

Displaying a family summary

Arranging the open forms

Closing all open forms at once

Aligning families vertically

Using the Timeline Window

Choosing layers

Choosing the selection's layer

Choosing all layers

Moving families to a layer

Removing families from a layer

Creating a new layer from selection

Managing layers

Choosing fonts and colours

Turning the Tree Area on and off

Turning the Button Bar on and off

Turning the Status Bar on and off

Turning the Tree Area Control on and off

Printing

Using the report control form

Printing the tree layout

Printing family details

Printing person details

Printing indices

Printing a descendant tree

Printing an ancestral tree

Printing an indented descendant tree

Printing a missing data report

Printing a timeline

Printing a census report

Printing source document details

Printing document repository details

Setting printer options

Setting page options

Previewing a report on the screen

Printing from a preview

Printing to text files

Copying printed pages to the clipboard

Importing / exporting

Importing a GEDCOM file

Exporting a GEDCOM file

Exporting Web pages

Customising Web pages

Exporting data to a delimited text file

Importing a text file into notes

Exporting a text file from notes

Exporting a report to a PDF file

General

Setting preferences

Editing the timeline

Customising the button bar

Setting date options

Converting dates

Setting options

Setting current database options

Choosing a family to move to when the tree is opened

Choosing the current database language

Setting regional / language options

Setting picture options

Exiting from the program

Checking for program updates

Reference

File menu

Edit menu

Search menu

View menu

Layers menu

Tools menu

Window menu

Options menu

Using the Tree Area Control

Selecting / defining a database name

Selecting a family

Selecting a person

Database fields

Additional LDS information

SQL syntax

Supported GEDCOM syntax

Timeline text file format

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

GEDCOM

Layer

LDS

Metaphone

OLE embedding

OLE linking

OLE object

Soundex

Tree Area

How to get support

How to contact us

Ordering / registration

Working with pictures

Kith and Kin Pro can store pictures and other images associated with a particular person, family or source. The pictures can optionally be printed in reports and included in Web pages.

The pictures are stored full-sized in files in the current database's \Pictures folder hierarchy. The program also creates a smaller thumbnail of the picture which is stored as part of the current family tree database. This allows you to quickly move through the available pictures.

The Pictures form displays a list of the images currently associated with the person, family or source named at the top of the form. Click on a description of the picture in the list and the thumbnail will appear.

When you make any changes to the data, the data form will become highlighted using the "Dialog editing indicator" colour. This indicates that the data is currently being edited and has not yet been saved to the database. Click on the Accept edit button to save the new data to the database, or the Cancel edit button to cancel any changes made.

Adding a new picture:

First click on the Add new image button to create a new record to store the image in.

Enter a Description of the picture which will be used as a caption for the picture in reports. If you want the picture to appear in reports and Web pages, set the "Include image in output" option.

Enter the Width and Height that the image should appear when printed. The units of measure used are those currently set in the Page setup form. For the best quality in printouts you should normally use images which are the width and height in pixels which give them the required physical width and height when printed on your printer. For example, if your printer has a resolution of 600 dpi (dots per inch) and you have a picture which you want to have a finished printed size of 3 inches wide by 2 inches high, then the image itself should be 1800 pixels wide by 1200 pixels high. If you want to use smaller images (in terms of pixels) Kith and Kin Pro will automatically scale pictures to fit the required Width and Height settings when printing but the print quality will not be as good.

The width and height fields are ignored in Web page output. The Web export feature allows you to choose an overall maximum size for thumbnail images to keep them uniform.

To add an image to the record, see "Acquiring a picture" below.

Click on the OK button to save the picture to the database.

Editing an existing picture:

To edit the data for an existing picture or to change the picture, first select the picture you want to change in the list at the top of the data form. The current data and thumbnail will appear in the boxes below the list. Modify the data and/or acquire a new picture (see below) and click on the Accept edit button.

Deleting a picture:

Delete an picture by selecting the required picture in the list at the top of the data form and then clicking on the Delete button.

Where are the image files stored?

By default, Kith and Kin Pro stores image files in the \Pictures folder of the current database. So if your database is called "Smith" and you are using the default database root folder, the image files will be stored in "C:\KKPro3Data\Smith\Pictures".

To make managing picture files easier, it is possible to have image files stored in user-defined subfolders, for instance \Pictures\Places or \Pictures\Headstones. To tell Kith and Kin Pro which folder to use for new image files, use "Options | Preferences | Pictures | Default folder".

Acquiring a picture:

Drag and drop image file(s) from a folder:

The simplest way to add existing image files to Kith and Kin Pro. Drag one or more image files from Windows Explorer and drop them into the Pictures form. If the image files are in one of the current database's \Pictures folder hierarchy then the new picture records will simply link to the existing files. If the image files are outside of the \Pictures folder hierarchy then a copy will be made in the default pictures folder.

Linking to an image file:

Click on the Link to file button or right-click on the thumbnail (even if it is blank) and then select Link to file. Kith and Kin Pro can import from most common image file formats.

If the selected image file is stored in the current database's \Pictures folders hierarchy then the new picture record will simply link to the existing file. This allows you to link several different people, families, sources or documents to the same image.

If the selected image file is stored outside of the \Pictures folder hierarchy it will be copied to the default pictures folder. A warning will appear if a copy already exists there and you should select the copy in the \Pictures folder hierarchy instead.

Pasting an image from the clipboard:

If you have copied an image from another program onto the clipboard, paste it into the current record by clicking on the Paste button, using Paste in the thumbnail pop-up menu, or pressing Ctrl+V.

The program will create a copy of the full-sized image in the default pictures folder. The file name will be the same as the Code number of the picture record. The file type will be that defined in Preferences

Scanning an image:

If you have a TWAIN compliant scanning device connected to your computer, you can scan images directly into Kith and Kin Pro.

If you have more than one TWAIN source, right-click on the thumbnail (even if it is blank) and then select Select scanner from the pop-up menu. Select the scanner that you want to use.

Click on the Scan button or select Scan from the pop-up menu or press F5 to scan the image. Kith and Kin Pro will open up the scanning window for your scanner. Proceed with the normal scanning operation. Some programs will close the window automatically when scanning is complete. If yours does not do that then close the window manually to return to Kith and Kin Pro.

The program will create a copy of the full-sized image in the default pictures folder. The file name will be the same as the Code number of the picture record. The file type will be that defined in Preferences

Sorting the pictures:

You can move the pictures around in the list to get the order you want, simply by dragging entries up and down the list with the left mouse button. When you start to drag an entry, a black line will appear indicating where the picture will be placed. Release the mouse button when the line is in the position you want.

The sorted picture order will be used when printing reports or exporting Web pages.

Full-sized image functions:

You can display the full-sized image by double-clicking on the thumbnail, the description in the pictures list, by using View in the thumbnail pop-up menu, or by pressing Ctrl+W.

If the picture is larger then the size of the screen it will be shrunk to fit if the "Shrink large images to fit screen" option is set in Preferences. You can override this setting by using "Shrink to screen" from the pop-up menu.

Right-click on the full-sized image to display the pop-up menu. From here you can also print the image and copy it to the clipboard.

When the full-sized image is visible click on it or on anything else to close it.

See also