Kith and Kin Pro manual

Kith and Kin Pro site SpanSoft main site

Kith and Kin Pro

Getting started

Introducing Kith and Kin Pro

Converting from older versions of Kith and Kin

Using Kith and KinPro with TreeDraw

Tutorials

Tutorial - Using the Tree Area

Tutorial - Working with person and family data forms

Tutorial - Simple searching

Tutorial - Searching using queries

Tutorial - Printing

Tutorial - Adding extra fields to people and families

Tutorial - Starting your own family tree

Tutorial - Importing a GEDCOM file

Tasks

Database maintenance

Starting a new database

Creating a clean database

Opening an existing database

Saving a database

Merging two databases

Copying a database

Copying part of a database

Changing the name of a database

Packing a database

Repairing a database

Clearing a database

Deleting a database

Adding and maintaining user-defined fields

Backing-up your data

Restoring data from a backup

Data maintenance

Adding a new family

Adding a new person

Editing an existing family

Editing an existing person

Marking probable links

Adding and maintaining aliases

Editing notes

Organising notes

Entering dates

Working with pictures

Working with objects

Adding and maintaining sources

Deleting a family

Deleting a person

Adding and maintaining source documents

Adding and maintaining source document repositories

Updating descriptions

Re-using an old person or family code

Updating death flags

Removing duplicate records

Editing data in bulk

Searching / querying

Searching for people

Seaching for families

Searching for sources

Using a query to find data

Calculating ages

Calculating phonetic codes

Displaying statistics

Displaying a relationship between two people

Searching for date errors / inconsistencies

Searching for events on a particular day

Searching for people who are not on the Tree Area

Displaying modified records

Screen

Moving around the Tree Area

Zooming in and out

Moving to a specific family

Selecting families using the mouse

Selecting families by relationship

Selecting all families

Moving families

Displaying a family summary

Arranging the open forms

Closing all open forms at once

Aligning families vertically

Using the Timeline Window

Choosing layers

Choosing the selection's layer

Choosing all layers

Moving families to a layer

Removing families from a layer

Creating a new layer from selection

Managing layers

Choosing fonts and colours

Turning the Tree Area on and off

Turning the Button Bar on and off

Turning the Status Bar on and off

Turning the Tree Area Control on and off

Printing

Using the report control form

Printing the tree layout

Printing family details

Printing person details

Printing indices

Printing a descendant tree

Printing an ancestral tree

Printing an indented descendant tree

Printing a missing data report

Printing a timeline

Printing a census report

Printing source document details

Printing document repository details

Setting printer options

Setting page options

Previewing a report on the screen

Printing from a preview

Printing to text files

Copying printed pages to the clipboard

Importing / exporting

Importing a GEDCOM file

Exporting a GEDCOM file

Exporting Web pages

Customising Web pages

Exporting data to a delimited text file

Importing a text file into notes

Exporting a text file from notes

Exporting a report to a PDF file

General

Setting preferences

Editing the timeline

Customising the button bar

Setting date options

Converting dates

Setting options

Setting current database options

Choosing a family to move to when the tree is opened

Choosing the current database language

Setting regional / language options

Setting picture options

Exiting from the program

Checking for program updates

Reference

File menu

Edit menu

Search menu

View menu

Layers menu

Tools menu

Window menu

Options menu

Using the Tree Area Control

Selecting / defining a database name

Selecting a family

Selecting a person

Database fields

Additional LDS information

SQL syntax

Supported GEDCOM syntax

Timeline text file format

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

GEDCOM

Layer

LDS

Metaphone

OLE embedding

OLE linking

OLE object

Soundex

Tree Area

How to get support

How to contact us

Ordering / registration

Editing an existing family

The family data form allows you manage all the data for a particular family. You can edit family details such as marriage date and any user-defined fields which you have assigned to families. You can add links to the people which make up this family; the father, mother and children.

When you make any changes to the data, the data form will become highlighted using the "Dialog editing indicator" colour. This indicates that the data is currently being edited and has not yet been saved to the database. Click on the Update button to save the new data to the database, or the Undo button to cancel any changes made. When you update a family's data the "Last updated" date is set to today and the "Record changed" flag is set. You can view a list of all the records which have been modified by using "Tools | Records modified".

Delete:  

Click on the Delete button to delete the entire family and close the form.

Close:  

Click on the Close button to close the form. You can have as many open data form as you wish and can switch between them at will.

Go to family:  

Click on the Go to button to scroll the Tree Area to the current family.


Using text edit fields:

To add or edit data in the "Marriage", "Divorce" or any user-defined field simply click the mouse on the field you want to change and start typing. Any date fields must have dates entered using the format defined in Preferences.

To speed up entering the same place names over and over, you can press F4 or right-click in a text edit field to display a pick-list of the last 20 entries made. Click on the required entry or use the down arrow key and press Return to enter the text into the current field. Press Escape to cancel the pick-list.


Father:

To add or edit the father, right-click the mouse or press F4 in the "Father" field and choose the appropriate command from the pop-up menu. If a father already exists you can also edit him by double-clicking on the "Father" field. Use Add to create a new person who will be used as the father for this family, Identify to link to someone who already exists, Edit to edit the data for an existing father and Remove to remove the link (this does not delete the person).


Mother:

The "Mother" field works in exactly the same way as the father field.


Children:

To add a new child to the family, right-click the mouse or press F4 in the "Children list" field and choose the appropriate command from the pop-up menu. Use Add to create a new person who will be identified as a child in this family and Identify to link to someone who already exists.

To edit or remove a child from the list, click on the child's name to highlight it and then right-click the mouse to bring up the pop-up menu. Use Edit to edit the data for the child and Remove to remove the link (this does not delete the person).

You can also edit a child by double-clicking on its name in the "Children list".

Children can be automatically sorted by birth/christening date if this option is set in Preferences. Sometimes it is necessary to sort a list of children manually (particularly if some have no dates). To do this the auto-sort option in Preferences must be off or you can override the auto-sort option by using the small Manual sort button at the bottom-left corner of the "Children list" (down indicates Auto-sort). Now you can re-arrange the children simply by dragging a child in the list to its new position. A curved arrow on the left side of the list indicates the position the child will take when you drop it. When you click on the Update button, the order of the children is fixed until the next time you click on the Update button for this family.


Notes:

You can have more than one note for each family and you can give each one a description to help you find it. The descriptions can be used in reports if you wish.

You can also give each note a privacy level code which allows you to keep some notes private, the lower the code, the less private the note is. For example you may have notes which you always want published in reports, GEDCOM files and Web pages; so you would give them a privacy level of 0. Other notes might be for your own private use such as reminders about the status of your research and you would give these a higher privacy level. When you come to publish the data, you can decide what level of notes to include.

The use of privacy level codes should be consistent throughout the database.

To add a new note click on the New note button and start typing in the notes field. When you make any changes to the notes data, the notes part of the data form will become highlighted using the "Dialog editing indicator" colour. This indicates that the notes data is currently being edited and has not yet been saved to the database. Click on the Accept edit button to save the new data to the database, or the Cancel edit button to cancel any changes made.

For larger notes, you can open the Notes Editor which has additional editing functions, by clicking on the Edit notes button or double-clicking in the notes field.

If you have more than one note, use the Previous note and Next note buttons to scroll through them. It does not matter in which order you enter separate notes, you can change their order later by using the "Organise notes" button.

Use the Delete note button to delete the currently displayed note.


Sources:  

To make a record of where you found the information which you are recording in the data form, click on an appropriate source button. For example, if you want a source record for the "Marriage date", click on the source button to the right of the Marriage details. User-defined fields share a single source button and you must select the appropriate user-defined field before clicking on the source button. Source buttons display a grey page icon when there are no sources stored and a yellow page icon when there are. This displays the Sources form where you can store information about the source document and repository. You can have more than one source for each data field.


Pictures:  

You can store pictures with a family's data and these can be used in some reports and on Web pages. Click on the Pictures button to open the Pictures form. The Pictures button displays a black icon when there are no pictures stored and a coloured icon when there are.


Objects:  

You can store OLE objects with a family's data. Objects are generally multi-media items such as sound or video clips which have been copied from another application and are not used in output. Click on the Objects button to open the Objects form. The Objects button displays a black icon when there are no objects stored and a coloured icon when there are.

See also

Download family history software with free 30-day trial. Our free to try software is for family history research and family trees. We specialize in free to try genealogy program available for download. Here users can download genealogy program for historians. Download genealogy software for family history. Why not download genealogy software for your ancestors history? It's free for 30 days. Free 30-day trial family history software. Users can download genealogy database program which is free-to-try. Download genealogy program to store your family tree, there is a free trial. Download genealogy software. You can download free trial versions of our genealogy program to store your family history. To store family history, download genealogy software. Import GEDCOM files and print family tree charts using our free to try genealogy software. Download our free to try program for researching your ancestors. Download family history software which is free to try and is used for ancestry research. Store your family tree in our genealogy software database. Store family trees using our free to try database program. Download family history program which is free to try. Download genealogy software for family history research. Our family history program is good for family history research.