Kith and Kin Pro manual

Kith and Kin Pro site SpanSoft main site

Kith and Kin Pro

Getting started

Introducing Kith and Kin Pro

Converting from older versions of Kith and Kin

Using Kith and KinPro with TreeDraw

Tutorials

Tutorial - Using the Tree Area

Tutorial - Working with person and family data forms

Tutorial - Simple searching

Tutorial - Searching using queries

Tutorial - Printing

Tutorial - Adding extra fields to people and families

Tutorial - Starting your own family tree

Tutorial - Importing a GEDCOM file

Tasks

Database maintenance

Starting a new database

Creating a clean database

Opening an existing database

Saving a database

Merging two databases

Copying a database

Copying part of a database

Changing the name of a database

Packing a database

Repairing a database

Clearing a database

Deleting a database

Adding and maintaining user-defined fields

Backing-up your data

Restoring data from a backup

Data maintenance

Adding a new family

Adding a new person

Editing an existing family

Editing an existing person

Marking probable links

Adding and maintaining aliases

Editing notes

Organising notes

Entering dates

Working with pictures

Working with objects

Adding and maintaining sources

Deleting a family

Deleting a person

Adding and maintaining source documents

Adding and maintaining source document repositories

Updating descriptions

Re-using an old person or family code

Updating death flags

Removing duplicate records

Editing data in bulk

Searching / querying

Searching for people

Seaching for families

Searching for sources

Using a query to find data

Calculating ages

Calculating phonetic codes

Displaying statistics

Displaying a relationship between two people

Searching for date errors / inconsistencies

Searching for events on a particular day

Searching for people who are not on the Tree Area

Displaying modified records

Screen

Moving around the Tree Area

Zooming in and out

Moving to a specific family

Selecting families using the mouse

Selecting families by relationship

Selecting all families

Moving families

Displaying a family summary

Arranging the open forms

Closing all open forms at once

Aligning families vertically

Using the Timeline Window

Choosing layers

Choosing the selection's layer

Choosing all layers

Moving families to a layer

Removing families from a layer

Creating a new layer from selection

Managing layers

Choosing fonts and colours

Turning the Tree Area on and off

Turning the Button Bar on and off

Turning the Status Bar on and off

Turning the Tree Area Control on and off

Printing

Using the report control form

Printing the tree layout

Printing family details

Printing person details

Printing indices

Printing a descendant tree

Printing an ancestral tree

Printing an indented descendant tree

Printing a missing data report

Printing a timeline

Printing a census report

Printing source document details

Printing document repository details

Setting printer options

Setting page options

Previewing a report on the screen

Printing from a preview

Printing to text files

Copying printed pages to the clipboard

Importing / exporting

Importing a GEDCOM file

Exporting a GEDCOM file

Exporting Web pages

Customising Web pages

Exporting data to a delimited text file

Importing a text file into notes

Exporting a text file from notes

Exporting a report to a PDF file

General

Setting preferences

Editing the timeline

Customising the button bar

Setting date options

Converting dates

Setting options

Setting current database options

Choosing a family to move to when the tree is opened

Choosing the current database language

Setting regional / language options

Setting picture options

Exiting from the program

Checking for program updates

Reference

File menu

Edit menu

Search menu

View menu

Layers menu

Tools menu

Window menu

Options menu

Using the Tree Area Control

Selecting / defining a database name

Selecting a family

Selecting a person

Database fields

Additional LDS information

SQL syntax

Supported GEDCOM syntax

Timeline text file format

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

GEDCOM

Layer

LDS

Metaphone

OLE embedding

OLE linking

OLE object

Soundex

Tree Area

How to get support

How to contact us

Ordering / registration

Customising Web pages

Kith and Kin Pro uses a CSS stylesheet to control the look and feel of the Web pages it exports. This enables the separation of Web page content (the HTML pages) from presentation, including elements such as the colors, fonts, and layout. The name of the stylesheet file must be "kkpro.css".


Folder hierarchy

When you export Web pages from Kith and Kin Pro, you must select the folder on your hard drive where you want the Web pages to be stored. This is the HTML folder. Inside the HTML folder, the program creates some extra subfolders for the following files:

Subfolder nameFiles
picturesFull-sized image files
thumbnailsThumbnail-sized image files
no-erasekkpro.css, return.gif, kkbkg.gif

The "no_erase" subfolder is created the first time that you export to the specified HTML folder. If you subsequently carry out another Web page export to the same HTML folder, the "no_erase" folder will not be cleared and the files in it will not be changed. This enables you make permanent changes to the CSS file and to be able to see the results quickly by simply opening one of the HTM files in the HTML folder. It also means that you can re-export the Web pages to reflect changes in the family tree database but retain your modified CSS stylesheet file.


return.gif

"return.gif" is a graphic file which is used as the "return to start" icon at the foot of every Web page. Kith and Kin Pro is supplied with several suitable icons in the "Web Source" folder or you can provide your own graphic. Copy the graphic file you want to use into the "no_erase" folder and rename it to "return.gif".


kkbkg.gif

"kkbkg.gif" is a graphic file which can be used as a background on every Web page but is only used in some stylesheets. It is only necessary to have this file if your stylesheet references it.


kkpro.css

"kkpro.css" is the CSS stylesheet. Kith and Kin Pro is supplied with several different stylesheets in the "Web Source" folder or you can modify the stylesheet to you own design. Copy the CSS file you want to use into the "no_erase" folder and rename it to "kkpro.css".


Modifying the CSS stylesheet file

The stylesheet file can be modified using a standard text editor such as NotePad. The file contains comments enclosed in "/*--*/", for example: /* Kith and Kin Pro stylesheet */, which help you identify which parts of the file are used for each part of a Web page.

Each statement has the following format:
    selector {style}

The selector identifies which HTML element to apply the style to, eg. body, p, ul. The style contains the instructions which will define the colour, spacing, etc, eg. color: #000000;. You must not change the "selector" names in the stylesheet. Kith and Kin Pro uses pre-defined selector names in the exported Web pages and these must match those in the stylesheet.

An example CSS statement might be:
    body {background-color: #FFFFFF; color: #000000; font-family: Verdana, Arial, Helvetica, sans-serif;}

This statement tells the HTML page that the "body" (ie. the visible part of the entire page) should have a background colour of #FFFFFF (ie. white - you could also use the word "white" here), font colour of #000000 (ie. black) and a font typeface of whatever is closest to Arial on the user's computer.

You can modify any of the "style" settings in the stylesheet to your own requirements.

For a complete reference to the CSS language, please see one of the many Web sites on the subject, for example htmlhelp.com

See also

Download family history software with free 30-day trial. Our free to try software is for family history research and family trees. We specialize in free to try genealogy program available for download. Here users can download genealogy program for historians. Download genealogy software for family history. Why not download genealogy software for your ancestors history? It's free for 30 days. Free 30-day trial family history software. Users can download genealogy database program which is free-to-try. Download genealogy program to store your family tree, there is a free trial. Download genealogy software. You can download free trial versions of our genealogy program to store your family history. To store family history, download genealogy software. Import GEDCOM files and print family tree charts using our free to try genealogy software. Download our free to try program for researching your ancestors. Download family history software which is free to try and is used for ancestry research. Store your family tree in our genealogy software database. Store family trees using our free to try database program. Download family history program which is free to try. Download genealogy software for family history research. Our family history program is good for family history research.