Kith and Kin Pro manual

Kith and Kin Pro site SpanSoft main site

Kith and Kin Pro

Getting started

Introducing Kith and Kin Pro

Converting from older versions of Kith and Kin

Using Kith and KinPro with TreeDraw

Tutorials

Tutorial - Using the Tree Area

Tutorial - Working with person and family data forms

Tutorial - Simple searching

Tutorial - Searching using queries

Tutorial - Printing

Tutorial - Adding extra fields to people and families

Tutorial - Starting your own family tree

Tutorial - Importing a GEDCOM file

Tasks

Database maintenance

Starting a new database

Creating a clean database

Opening an existing database

Saving a database

Merging two databases

Copying a database

Copying part of a database

Changing the name of a database

Packing a database

Repairing a database

Clearing a database

Deleting a database

Adding and maintaining user-defined fields

Backing-up your data

Restoring data from a backup

Data maintenance

Adding a new family

Adding a new person

Editing an existing family

Editing an existing person

Marking probable links

Adding and maintaining aliases

Editing notes

Organising notes

Entering dates

Working with pictures

Working with objects

Adding and maintaining sources

Deleting a family

Deleting a person

Adding and maintaining source documents

Adding and maintaining source document repositories

Updating descriptions

Re-using an old person or family code

Updating death flags

Removing duplicate records

Editing data in bulk

Searching / querying

Searching for people

Seaching for families

Searching for sources

Using a query to find data

Calculating ages

Calculating phonetic codes

Displaying statistics

Displaying a relationship between two people

Searching for date errors / inconsistencies

Searching for events on a particular day

Searching for people who are not on the Tree Area

Displaying modified records

Screen

Moving around the Tree Area

Zooming in and out

Moving to a specific family

Selecting families using the mouse

Selecting families by relationship

Selecting all families

Moving families

Displaying a family summary

Arranging the open forms

Closing all open forms at once

Aligning families vertically

Using the Timeline Window

Choosing layers

Choosing the selection's layer

Choosing all layers

Moving families to a layer

Removing families from a layer

Creating a new layer from selection

Managing layers

Choosing fonts and colours

Turning the Tree Area on and off

Turning the Button Bar on and off

Turning the Status Bar on and off

Turning the Tree Area Control on and off

Printing

Using the report control form

Printing the tree layout

Printing family details

Printing person details

Printing indices

Printing a descendant tree

Printing an ancestral tree

Printing an indented descendant tree

Printing a missing data report

Printing a timeline

Printing a census report

Printing source document details

Printing document repository details

Setting printer options

Setting page options

Previewing a report on the screen

Printing from a preview

Printing to text files

Copying printed pages to the clipboard

Importing / exporting

Importing a GEDCOM file

Exporting a GEDCOM file

Exporting Web pages

Customising Web pages

Exporting data to a delimited text file

Importing a text file into notes

Exporting a text file from notes

Exporting a report to a PDF file

General

Setting preferences

Editing the timeline

Customising the button bar

Setting date options

Converting dates

Setting options

Setting current database options

Choosing a family to move to when the tree is opened

Choosing the current database language

Setting regional / language options

Setting picture options

Exiting from the program

Checking for program updates

Reference

File menu

Edit menu

Search menu

View menu

Layers menu

Tools menu

Window menu

Options menu

Using the Tree Area Control

Selecting / defining a database name

Selecting a family

Selecting a person

Database fields

Additional LDS information

SQL syntax

Supported GEDCOM syntax

Timeline text file format

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

GEDCOM

Layer

LDS

Metaphone

OLE embedding

OLE linking

OLE object

Soundex

Tree Area

How to get support

How to contact us

Ordering / registration

Editing an existing person

The person data form allows you manage all the data for a particular person. You can edit person details such as birth date and any user-defined fields which you have assigned to people. You can add links to the families where this person appears; the family where he is a child and marriages.

When you make any changes to the data, the data form will become highlighted using the "Dialog editing indicator" colour. This indicates that the data is currently being edited and has not yet been saved to the database. Click on the Update button to save the new data to the database, or the Undo button to cancel any changes made. When you update a person's data the "Last updated" date is set to today and the "Record changed" flag is set. You can view a list of all the records which have been modified by using "Tools | Records modified".

Delete:  

Click on the Delete button to delete the entire person and close the form.

Close:  

Click on the Close button to close the form. You can have as many open data form as you wish and can switch between them at will.


Using text edit fields:

To add or edit data in the "Surname", "Firstnames", "Birth", "Christening", "Death" , "Burial" or any user-defined field simply click the mouse on the field you want to change and start typing. Any date fields must have dates entered using the format defined in Preferences.

The "Surname" field can be set to convert all letters to upper-case. If you want to enter lower-case letters you must either turn off the option in Preferences or you can override the upper-case option by using the small Normal case button to the left of the "Surname" field (down indicates upper-case only). Upper-case is normally used for surnames to make it easier to identify the surname in reports.

To speed up entering the same names over and over, you can press F4 or right-click in a text edit field to display a pick-list of the last 20 entries made. Click on the required entry or use the down arrow key and press Return to enter the text into the current field. Press Escape to cancel the pick-list.


Deceased:

Set this flag to indicate that the person is dead. You can set or clear this flag irrespective of whether the person has any death or burial details. Kith and Kin Pro uses this flag to confirm that the person is dead; the existence of death/burial details does not affect this. You can choose whether new people should have this flag set or clear by default in Preferences.


Alias:  

A person can have more than one name. It's useful to record this so that you can search and index people by all their names, particularly women who changed their surnames when they got married.

To add an alias for this person click on the Alias button. This opens the Alias form.

It is possible to have the program automatically create an alias for a woman when she gets married. Set this option in Preferences.


Child of family:

To add or edit the family where this person appears as a child, right-click the mouse or press F2 in the "Child of family" field and choose the appropriate command from the pop-up menu. If a family already exists you can also edit it by double-clicking on the "Child of family" field. Use Add to create a new family which will have this person as a child, Identify to link to a family which already exists, Edit to edit the data for an family and Remove to remove the link (this does not delete the family).

If the family is not on the current layer this field will be coloured orange and certain functions will be disabled in the popup menu. To enable all the normal functions, right-click and use Switch to layer. This will change the current layer to the same layer as the "Child of family".


Marriages:

To add a new marriage to the person, right-click the mouse or press F2 in the "Marriages list" field and choose the appropriate command from the pop-up menu. Use Add to create a new family who will have this person as a parent and Identify to link to a family which already exists.

To edit or remove a marriage from the list, click on the family to highlight it and then right-click the mouse to bring up the pop-up menu. Use Edit to edit the data for the marriage and Remove to remove the link (this does not delete the family).

You can also edit a marriage by double-clicking on it in the "Marriages list".

If a family in the Marriages List is not on the current layer it will be coloured orange and certain functions will be disabled in the popup menu. To enable all the normal functions, select the marriage, right-click and use Switch to layer. This will change the current layer to the same layer as the selected marriage.

Marriages can be automatically sorted by marriage date if this option is set in Preferences. Sometimes it is necessary to sort a list of marriages manually (particularly if some have no dates). To do this the auto-sort option in Preferences must be off or you can override the auto-sort option by using the small Manual sort button at the bottom-left corner of the "Marriages list" (down indicates Auto-sort). Now you can re-arrange the marriages simply by dragging a marriage in the list to its new position. A curved arrow on the left side of the list indicates the position the marriage will take when you drop it. When you click on the Update button, the order of the marriages is fixed until the next time you click on the Update button for this person.


Notes:

You can have more than one note for each person and you can give each one a description to help you find it. The descriptions can be used in reports if you wish.

You can also give each note a privacy level code which allows you to keep some notes private, the lower the code, the less private the note is. For example you may have notes which you always want published in reports, GEDCOM files and Web pages; so you would give them a privacy level of 0. Other notes might be for your own private use such as reminders about the status of your research and you would give these a higher privacy level. When you come to publish the data, you can decide what level of notes to include.

The use of privacy level codes should be consistent throughout the database.

To add a new note click on the New note button and start typing in the notes field. When you make any changes to the notes data, the notes part of the data form will become highlighted using the "Dialog editing indicator" colour. This indicates that the notes data is currently being edited and has not yet been saved to the database. Click on the Accept edit button to save the new data to the database, or the Cancel edit button to cancel any changes made.

For larger notes, you can open the Notes Editor which has additional editing functions, by clicking on the Edit notes button or double-clicking in the notes field.

If you have more than one note, use the Previous note and Next note buttons to scroll through them. It does not matter in which order you enter separate notes, you can change their order later by using the "Organise notes" button.

Use the Delete note button to delete the currently displayed note.


Sources:  

To make a record of where you found the information which you are recording in the data form, click on an appropriate source button. For example, if you want a source record for the "Birth date", click on the source button to the right of the Birth details. User-defined fields share a single source button and you must select the appropriate user-defined field before clicking on the source button. Source buttons display a grey page icon when there are no sources stored and a yellow page icon when there are. This displays the Sources form where you can store information about the source document and repository. You can have more than one source for each data field.


Pictures:  

You can store pictures with a person's data and these can be used in some reports and on Web pages. Click on the Pictures button to open the Pictures form. The Pictures button displays a black icon when there are no pictures stored and a coloured icon when there are.


Objects:  

You can store OLE objects with a person's data. Objects are generally multi-media items such as sound or video clips which have been copied from another application and are not used in output. Click on the Objects button to open the Objects form. The Objects button displays a black icon when there are no objects stored and a coloured icon when there are.

See also

Download genealogy software with free 30-day trial. Free to try software is for genealogy and family history. Import GEDCOM files and print genealogy charts using our free to try family history program. Download our free to try family tree program. Free 30-day trial family history program. Historians can download genealogy database program which is free-to-try. Download genealogy program to store your family tree, there is a free trial. Download genealogy software. You can download free trial versions of our family tree software to store your family history. To store family history, download genealogy software. Download family history software which is free to try and is used for genealogy. Store your family tree in our genealogy software database. Store family trees using our free to try family tree program. Download genealogy program which is free to try. Download genealogy software for family history. Why not download genealogy software for your ancestors history. It's free for 30 days. We specialize in free to try genealogy software available for download. Here users can download family tree software for historians. Download genealogy software for family history research. Our database program is the best for family history research and tracing your ancestors.