Kith and Kin Pro manual

Kith and Kin Pro site SpanSoft main site

Kith and Kin Pro

Getting started

Introducing Kith and Kin Pro

Converting from older versions of Kith and Kin

Using Kith and KinPro with TreeDraw

Tutorials

Tutorial - Using the Tree Area

Tutorial - Working with person and family data forms

Tutorial - Simple searching

Tutorial - Searching using queries

Tutorial - Printing

Tutorial - Adding extra fields to people and families

Tutorial - Starting your own family tree

Tutorial - Importing a GEDCOM file

Tasks

Database maintenance

Starting a new database

Creating a clean database

Opening an existing database

Saving a database

Merging two databases

Copying a database

Copying part of a database

Changing the name of a database

Packing a database

Repairing a database

Clearing a database

Deleting a database

Adding and maintaining user-defined fields

Backing-up your data

Restoring data from a backup

Data maintenance

Adding a new family

Adding a new person

Editing an existing family

Editing an existing person

Marking probable links

Adding and maintaining aliases

Editing notes

Organising notes

Entering dates

Working with pictures

Working with objects

Adding and maintaining sources

Deleting a family

Deleting a person

Adding and maintaining source documents

Adding and maintaining source document repositories

Updating descriptions

Re-using an old person or family code

Updating death flags

Removing duplicate records

Editing data in bulk

Searching / querying

Searching for people

Seaching for families

Searching for sources

Using a query to find data

Calculating ages

Calculating phonetic codes

Displaying statistics

Displaying a relationship between two people

Searching for date errors / inconsistencies

Searching for events on a particular day

Searching for people who are not on the Tree Area

Displaying modified records

Screen

Moving around the Tree Area

Zooming in and out

Moving to a specific family

Selecting families using the mouse

Selecting families by relationship

Selecting all families

Moving families

Displaying a family summary

Arranging the open forms

Closing all open forms at once

Aligning families vertically

Using the Timeline Window

Choosing layers

Choosing the selection's layer

Choosing all layers

Moving families to a layer

Removing families from a layer

Creating a new layer from selection

Managing layers

Choosing fonts and colours

Turning the Tree Area on and off

Turning the Button Bar on and off

Turning the Status Bar on and off

Turning the Tree Area Control on and off

Printing

Using the report control form

Printing the tree layout

Printing family details

Printing person details

Printing indices

Printing a descendant tree

Printing an ancestral tree

Printing an indented descendant tree

Printing a missing data report

Printing a timeline

Printing a census report

Printing source document details

Printing document repository details

Setting printer options

Setting page options

Previewing a report on the screen

Printing from a preview

Printing to text files

Copying printed pages to the clipboard

Importing / exporting

Importing a GEDCOM file

Exporting a GEDCOM file

Exporting Web pages

Customising Web pages

Exporting data to a delimited text file

Importing a text file into notes

Exporting a text file from notes

Exporting a report to a PDF file

General

Setting preferences

Editing the timeline

Customising the button bar

Setting date options

Converting dates

Setting options

Setting current database options

Choosing a family to move to when the tree is opened

Choosing the current database language

Setting regional / language options

Setting picture options

Exiting from the program

Checking for program updates

Reference

File menu

Edit menu

Search menu

View menu

Layers menu

Tools menu

Window menu

Options menu

Using the Tree Area Control

Selecting / defining a database name

Selecting a family

Selecting a person

Database fields

Additional LDS information

SQL syntax

Supported GEDCOM syntax

Timeline text file format

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

GEDCOM

Layer

LDS

Metaphone

OLE embedding

OLE linking

OLE object

Soundex

Tree Area

How to get support

How to contact us

Ordering / registration

Tutorial - Starting your own family tree

Subject: Creating a new database.

Creating a blank database

When you are ready to start entering data for your own family tree you will need to start with a blank database.

Click on "File" in the main menu, then "Database" and then "New". This brings up a form where you can enter a name for the new family tree. Enter the name into the "Database name" box. You can use as many characters as you like and include spaces. You cannot use characters which Windows considers invalid for file names, eg: \ and /. The "OK" button will become enabled when you have entered a valid name.

The list box below "Database name" shows the names of other available family trees. Probably it will just show "Sample_V3".

When you have entered a new name click on the "OK" button. Kith and Kin Pro will create and open a new, blank database. You will see the main window caption change to show the new database name you have entered.

Unless you open or create another database, Kith and Kin Pro will always open your new database when it starts up. The program always opens the last-used database when it starts up.

If you intend to import your family tree data from an existing GEDCOM file (perhaps you were using different software previously), go on to "Importing a GEDCOM file".

Entering new people and families

You can start entering your data at any point in the family tree you like.

Let's say you start with your own family. Click on "Edit" in the main menu and then "Add family". This opens up a blank family data form for you to fill in and adds its family rectangle to the Tree Area.

Enter the marriage and/or divorce details. Note that dates must be entered in the format specified in Preferences. The default format is "DD MMM YYYY", so if you haven't changed the format or selected a different regional file, you must enter dates like this: "25 Dec 1995". If you don't know part of the date you can omit it, eg. "Dec 1995" or "1995". You can't omit the year part of a date but you can put anything in a date field if you preceed it with an apostrophe "'". This tells Kith and Kin Pro to ignore the entry as a date but just store it as text.

Click on the "Update" button in the top-right corner of the form. This saves the new family information to the database on your hard drive. Changes that you make to the data in Kith and Kin Pro are written immediately to the hard drive when you click on the "Update" buttons.

Now you need to add the parents and children. Let's start with the father. Place the mouse cursor over the "Father" box, click the right mouse button and choose "Add" from the pop-up menu. This opens up a blank person data form in the same way as we opened a new family data form to start with. The difference is that the program has automatically linked this person to the family as the father.

Enter the person's names and details and click on the "Update" button. You will see that the original family data form has had its caption updated to show the name of the new father.

Go back to the original family data form by clicking on its caption and enter the mother and children in the same way.

If you find that you have too many data forms open to be able to find the one you want, press CTRL+L to close all the data forms at once. You will see now that a new family rectangle has been created in the middle of the Tree Area. Kith and Kin Pro always tries to position new family rectangles close to any families which it might be related to. If the new family is not linked to any other family, it will be positioned in the current centre of the screen.

Next tutorial - Importing a GEDCOM file

Download family history software with free 30-day trial. Our free to try software is for family history research and family trees. We specialize in free to try genealogy program available for download. Here users can download genealogy program for historians. Download genealogy software for family history. Why not download genealogy software for your ancestors history? It's free for 30 days. Free 30-day trial family history software. Users can download genealogy database program which is free-to-try. Download genealogy program to store your family tree, there is a free trial. Download genealogy software. You can download free trial versions of our genealogy program to store your family history. To store family history, download genealogy software. Import GEDCOM files and print family tree charts using our free to try genealogy software. Download our free to try program for researching your ancestors. Download family history software which is free to try and is used for ancestry research. Store your family tree in our genealogy software database. Store family trees using our free to try database program. Download family history program which is free to try. Download genealogy software for family history research. Our family history program is good for family history research.