Kith and Kin Pro manual

Kith and Kin Pro site SpanSoft main site

Kith and Kin Pro

Getting started

Introducing Kith and Kin Pro

Converting from older versions of Kith and Kin

Using Kith and KinPro with TreeDraw

Tutorials

Tutorial - Using the Tree Area

Tutorial - Working with person and family data forms

Tutorial - Simple searching

Tutorial - Searching using queries

Tutorial - Printing

Tutorial - Adding extra fields to people and families

Tutorial - Starting your own family tree

Tutorial - Importing a GEDCOM file

Tasks

Database maintenance

Starting a new database

Creating a clean database

Opening an existing database

Saving a database

Merging two databases

Copying a database

Copying part of a database

Changing the name of a database

Packing a database

Repairing a database

Clearing a database

Deleting a database

Adding and maintaining user-defined fields

Backing-up your data

Restoring data from a backup

Data maintenance

Adding a new family

Adding a new person

Editing an existing family

Editing an existing person

Marking probable links

Adding and maintaining aliases

Editing notes

Organising notes

Entering dates

Working with pictures

Working with objects

Adding and maintaining sources

Deleting a family

Deleting a person

Adding and maintaining source documents

Adding and maintaining source document repositories

Updating descriptions

Re-using an old person or family code

Updating death flags

Removing duplicate records

Editing data in bulk

Searching / querying

Searching for people

Seaching for families

Searching for sources

Using a query to find data

Calculating ages

Calculating phonetic codes

Displaying statistics

Displaying a relationship between two people

Searching for date errors / inconsistencies

Searching for events on a particular day

Searching for people who are not on the Tree Area

Displaying modified records

Screen

Moving around the Tree Area

Zooming in and out

Moving to a specific family

Selecting families using the mouse

Selecting families by relationship

Selecting all families

Moving families

Displaying a family summary

Arranging the open forms

Closing all open forms at once

Aligning families vertically

Using the Timeline Window

Choosing layers

Choosing the selection's layer

Choosing all layers

Moving families to a layer

Removing families from a layer

Creating a new layer from selection

Managing layers

Choosing fonts and colours

Turning the Tree Area on and off

Turning the Button Bar on and off

Turning the Status Bar on and off

Turning the Tree Area Control on and off

Printing

Using the report control form

Printing the tree layout

Printing family details

Printing person details

Printing indices

Printing a descendant tree

Printing an ancestral tree

Printing an indented descendant tree

Printing a missing data report

Printing a timeline

Printing a census report

Printing source document details

Printing document repository details

Setting printer options

Setting page options

Previewing a report on the screen

Printing from a preview

Printing to text files

Copying printed pages to the clipboard

Importing / exporting

Importing a GEDCOM file

Exporting a GEDCOM file

Exporting Web pages

Customising Web pages

Exporting data to a delimited text file

Importing a text file into notes

Exporting a text file from notes

Exporting a report to a PDF file

General

Setting preferences

Editing the timeline

Customising the button bar

Setting date options

Converting dates

Setting options

Setting current database options

Choosing a family to move to when the tree is opened

Choosing the current database language

Setting regional / language options

Setting picture options

Exiting from the program

Checking for program updates

Reference

File menu

Edit menu

Search menu

View menu

Layers menu

Tools menu

Window menu

Options menu

Using the Tree Area Control

Selecting / defining a database name

Selecting a family

Selecting a person

Database fields

Additional LDS information

SQL syntax

Supported GEDCOM syntax

Timeline text file format

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

GEDCOM

Layer

LDS

Metaphone

OLE embedding

OLE linking

OLE object

Soundex

Tree Area

How to get support

How to contact us

Ordering / registration

Adding and maintaining sources

Kith and Kin Pro allows you to record the sources of information that you have discovered and whether you consider that information reliable.

Source details are recorded in three parts; (1) the source reference, (2) the source document and (3) the document repository. The source reference (1) holds the page number and quality of data and is a reference to a source document (2). The source document (2) holds the details of the physical source document; title, author, media, etc and also references a repository (3). The document repository (3) holds details of where documents are kept; name, address, etc.

Using these three data types it is possible to store a single record for a source document which is referenced by several sources in different people/families. Similarly a single document repository can be referenced by several documents.

For example: A Robert GORDON is mentioned in a book called "Glimpses of Kinross-shire in the Past" available from Dunfermline Central Library. In the data form for Robert GORDON a "general" source is stored which records this fact. The source contains the page number "82" and the quality of data is flagged as "Questionable" (since we are not sure if this book is referring to the person in our tree). The source document (which the source points to) contains Title="Glimpses of Kinross-shire in the Past", Author="T M Tod" and other details about the publication. The document record itself points to a repository record containing Name="Dunfermline Central Library" and details about the library. Since this library contains many thousands of other books it is possible that we will find other source documents there which we want to record. These source documents will point to the same "Dunfermline Central Library" repository record. This gives the data a sense of documents "belonging to" a repository and, similarly, sources "belonging to" documents.

Note that user-defined fields with any of the following GEDCOM tags should not have source references attached when exporting to a GEDCOM file: RFN, AFN, REFN and RIN.

Source references:

Before you can add details about a source document or repository you must add a new source reference. Click on the New reference button and enter the "Page number", "Quality of data" and any "Notes". You can also add pictures to the source reference by clicking on the Pictures button.

When you make any changes to the data, the relevant part of the data form will become highlighted using the "Dialog editing indicator" colour. This indicates that the data is currently being edited and has not yet been saved to the database. Click on the Accept edit button to save the new data to the database, or the Cancel edit button to cancel any changes made.

You can have more than one source reference for each person or family field. For example, a person might have two sources for his birth date, a birth certificate and an entry in a family bible. Scroll between source references by using the Previous reference and Next reference buttons.

To edit the data for an existing source reference, first scroll to the reference you want to change. The current data will appear in the edit boxes. Modify the data and click on the Accept edit button.

Delete a source reference by scrolling to the reference you require and clicking on the Delete this reference button.

Source documents:

Each source reference points to a source document. Select the source reference you require.

Add a new source document by clicking on the New document button and enter the information for the document. Click on the OK button to save the new data to the database, or the Cancel button to cancel any changes made.

If the source document already exists in the database you should use the Select document button to make the source reference point at the existing record.

Edit the current source document by clicking on the Edit document button. Click on the Ok button to save the modified data.

You can also add pictures to the source reference by clicking on the Pictures button.

You can also edit source document details directly.

Remove the reference to the current document by clicking on the Remove document button. This does not delete the document record only the reference to it from the current source reference.

Document repositories:

Each source document points to a source repository.

Add a new source repository by clicking on the New repository button and enter the information for the repository. Click on the OK button to save the new data to the database, or the Cancel button to cancel any changes made.

If the repository already exists in the database you should use the Select repository button to make the source document point at the existing record.

Edit the current repository by clicking on the Edit repository button. Click on the Ok button to save the modified data.

You can also edit repository details directly.

Remove the reference to the current repository by clicking on the Remove repository button. This does not delete the repository record only the reference to it from the current source document.

See also