Kith and Kin Pro manual

Kith and Kin Pro site SpanSoft main site

Kith and Kin Pro

Getting started

Introducing Kith and Kin Pro

Converting from older versions of Kith and Kin

Using Kith and KinPro with TreeDraw

Tutorials

Tutorial - Using the Tree Area

Tutorial - Working with person and family data forms

Tutorial - Simple searching

Tutorial - Searching using queries

Tutorial - Printing

Tutorial - Adding extra fields to people and families

Tutorial - Starting your own family tree

Tutorial - Importing a GEDCOM file

Tasks

Database maintenance

Starting a new database

Creating a clean database

Opening an existing database

Saving a database

Merging two databases

Copying a database

Copying part of a database

Changing the name of a database

Packing a database

Repairing a database

Clearing a database

Deleting a database

Adding and maintaining user-defined fields

Backing-up your data

Restoring data from a backup

Data maintenance

Adding a new family

Adding a new person

Editing an existing family

Editing an existing person

Marking probable links

Adding and maintaining aliases

Editing notes

Organising notes

Entering dates

Working with pictures

Working with objects

Adding and maintaining sources

Deleting a family

Deleting a person

Adding and maintaining source documents

Adding and maintaining source document repositories

Updating descriptions

Re-using an old person or family code

Updating death flags

Removing duplicate records

Editing data in bulk

Searching / querying

Searching for people

Seaching for families

Searching for sources

Using a query to find data

Calculating ages

Calculating phonetic codes

Displaying statistics

Displaying a relationship between two people

Searching for date errors / inconsistencies

Searching for events on a particular day

Searching for people who are not on the Tree Area

Displaying modified records

Screen

Moving around the Tree Area

Zooming in and out

Moving to a specific family

Selecting families using the mouse

Selecting families by relationship

Selecting all families

Moving families

Displaying a family summary

Arranging the open forms

Closing all open forms at once

Aligning families vertically

Using the Timeline Window

Choosing layers

Choosing the selection's layer

Choosing all layers

Moving families to a layer

Removing families from a layer

Creating a new layer from selection

Managing layers

Choosing fonts and colours

Turning the Tree Area on and off

Turning the Button Bar on and off

Turning the Status Bar on and off

Turning the Tree Area Control on and off

Printing

Using the report control form

Printing the tree layout

Printing family details

Printing person details

Printing indices

Printing a descendant tree

Printing an ancestral tree

Printing an indented descendant tree

Printing a missing data report

Printing a timeline

Printing a census report

Printing source document details

Printing document repository details

Setting printer options

Setting page options

Previewing a report on the screen

Printing from a preview

Printing to text files

Copying printed pages to the clipboard

Importing / exporting

Importing a GEDCOM file

Exporting a GEDCOM file

Exporting Web pages

Customising Web pages

Exporting data to a delimited text file

Importing a text file into notes

Exporting a text file from notes

Exporting a report to a PDF file

General

Setting preferences

Editing the timeline

Customising the button bar

Setting date options

Converting dates

Setting options

Setting current database options

Choosing a family to move to when the tree is opened

Choosing the current database language

Setting regional / language options

Setting picture options

Exiting from the program

Checking for program updates

Reference

File menu

Edit menu

Search menu

View menu

Layers menu

Tools menu

Window menu

Options menu

Using the Tree Area Control

Selecting / defining a database name

Selecting a family

Selecting a person

Database fields

Additional LDS information

SQL syntax

Supported GEDCOM syntax

Timeline text file format

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

GEDCOM

Layer

LDS

Metaphone

OLE embedding

OLE linking

OLE object

Soundex

Tree Area

How to get support

How to contact us

Ordering / registration

Importing a GEDCOM file

Kith and Kin Pro supports version 5.5 of the GEDCOM standard, as used by the majority of genealogy programs. The program also implements some enhancements to the standard which allows it to read most previous GEDCOM versions which are not always compatible with V5.5.

Select the GEDCOM file which you wish to import. The incoming data will be merged with the data in the current database. If you want to create a new database based on the GEDCOM file, use File | Database | New or File | Database | New clean before starting the import process.

Kith and Kin Pro will read the file header from the selected file and display it so that you can verify that you have the correct file. You can now select several options which define how the GEDCOM file will be imported.

Display submitter/statistics when finished:

Set this option if you want to see the name/address of the file submitter and how many records were read. This also gives you the chance to view any errors. Errors encountered during a GEDCOM import are always reported in the GEDERR.TXT file and you can view this file using Windows Notepad by clicking on the Errors button on the statistics form. Very often you will find errors reported which do not affect the integrity of the GEDCOM import. For example, "OBJE" (object) tags are ignored.

Add a general source to every imported record:

Set this option if you wish to add the same source reference to every imported person and family. This helps to later identify the people and families which were imported from this GEDCOM file. After clicking on the "Continue" button you will be presented with the usual source reference form where you can add the reference details.

Put additional data in notes:

"Additional data", is GEDCOM data which Kith and Kin Pro recognises, but has no specific field for. By setting this option any extra data will be added to the appropriate set of notes. See Supported GEDCOM syntax for a list of recognised extra data.

List additional data in GEDERR.TXT:

By setting this option any extra data (see above) will be added to the GEDCOM import error file, GEDERR.TXT.

Convert invalid dates to text:

By setting this option any dates encountered which are invalid (eg. they do not conform to the GEDCOM standard date format DD MMM YYYY) are imported but are converted to date phrases.

Space out CONCed data for notes:

Some programs export notes in GEDCOM files using a CONC tag to split long notes over several lines in the GEDCOM file. Sometimes the program splits the line at a space character, which is not allowed. This makes Kith and Kin Pro join two words together when it imports the file. To prevent this, set this option and an extra space character will be inserted at the beginning of every CONC line. This does not affect other types of data which also use the CONC tag.

Uppercase surnames:

Set this option to automatically force surnames into all upper case.

Duplicate tags:

GEDCOM V5.5 requires that the first occurrence of a series of duplicated tags should be the one that is used in the program. For example, if a person has more than one name then there would be several NAME tags for him in the GEDCOM file. Kith and Kin Pro will use the first tag it comes across if the Use first occurrence option is set.

Some previous versions of GEDCOM accepted the last occurrence of multiple tags as the "genuine" one. If this is the case for the GEDCOM file you are importing, set the Use last occurrence option.

IBM (DOS) character set code page:

GEDCOM files created with the IBMPC character set (usually from a DOS program) may have been written using one of the alternative DOS code pages. These pages are generally used in non-English speaking countries and contain extra characters such as "" to cover the additional diacritics used in their language.

You can select one of the following code pages and Kith and Kin Pro will convert the incoming extra characters into the appropriate ANSI characters for use in Windows. If you are in doubt about which code page was used to create the GEDCOM file, assume it was 437 English.


Code pages supported:

Multiple files:

If the program encounters the end of a GEDCOM file before finding the TRLR record, it assumes that the file has been split over more than one disk (or file). You will be prompted to insert the disk containing the next file in sequence. GEDCOM files split into several files are named <filename>.GED, <filename>.G00, <filename>.G01, etc, where <filename>.GED is the filename originally specified for input.

User-defined fields:

If you have set up GEDCOM tags for any user-defined fields which you have added to the person or family tables, Kith and Kin Pro will import the corresponding data from the GEDCOM file into these fields.

Note on character sets:

Kith and Kin Pro will automatically detect which character set has been used to create the GEDCOM file. ANSI, ANSEL, Unicode, UTF-8, IBMPC (DOS) and Apple MAC are all supported. Please make sure that the GEDCOM file was written using one of these sets.

See also