Kith and Kin Pro manual

Kith and Kin Pro site SpanSoft main site

Kith and Kin Pro

Getting started

Introducing Kith and Kin Pro

Converting from older versions of Kith and Kin

Using Kith and KinPro with TreeDraw

Tutorials

Tutorial - Using the Tree Area

Tutorial - Working with person and family data forms

Tutorial - Simple searching

Tutorial - Searching using queries

Tutorial - Printing

Tutorial - Adding extra fields to people and families

Tutorial - Starting your own family tree

Tutorial - Importing a GEDCOM file

Tasks

Database maintenance

Starting a new database

Creating a clean database

Opening an existing database

Saving a database

Merging two databases

Copying a database

Copying part of a database

Changing the name of a database

Packing a database

Repairing a database

Clearing a database

Deleting a database

Adding and maintaining user-defined fields

Backing-up your data

Restoring data from a backup

Data maintenance

Adding a new family

Adding a new person

Editing an existing family

Editing an existing person

Marking probable links

Adding and maintaining aliases

Editing notes

Organising notes

Entering dates

Working with pictures

Working with objects

Adding and maintaining sources

Deleting a family

Deleting a person

Adding and maintaining source documents

Adding and maintaining source document repositories

Updating descriptions

Re-using an old person or family code

Updating death flags

Removing duplicate records

Editing data in bulk

Searching / querying

Searching for people

Seaching for families

Searching for sources

Using a query to find data

Calculating ages

Calculating phonetic codes

Displaying statistics

Displaying a relationship between two people

Searching for date errors / inconsistencies

Searching for events on a particular day

Searching for people who are not on the Tree Area

Displaying modified records

Screen

Moving around the Tree Area

Zooming in and out

Moving to a specific family

Selecting families using the mouse

Selecting families by relationship

Selecting all families

Moving families

Displaying a family summary

Arranging the open forms

Closing all open forms at once

Aligning families vertically

Using the Timeline Window

Choosing layers

Choosing the selection's layer

Choosing all layers

Moving families to a layer

Removing families from a layer

Creating a new layer from selection

Managing layers

Choosing fonts and colours

Turning the Tree Area on and off

Turning the Button Bar on and off

Turning the Status Bar on and off

Turning the Tree Area Control on and off

Printing

Using the report control form

Printing the tree layout

Printing family details

Printing person details

Printing indices

Printing a descendant tree

Printing an ancestral tree

Printing an indented descendant tree

Printing a missing data report

Printing a timeline

Printing a census report

Printing source document details

Printing document repository details

Setting printer options

Setting page options

Previewing a report on the screen

Printing from a preview

Printing to text files

Copying printed pages to the clipboard

Importing / exporting

Importing a GEDCOM file

Exporting a GEDCOM file

Exporting Web pages

Customising Web pages

Exporting data to a delimited text file

Importing a text file into notes

Exporting a text file from notes

Exporting a report to a PDF file

General

Setting preferences

Editing the timeline

Customising the button bar

Setting date options

Converting dates

Setting options

Setting current database options

Choosing a family to move to when the tree is opened

Choosing the current database language

Setting regional / language options

Setting picture options

Exiting from the program

Checking for program updates

Reference

File menu

Edit menu

Search menu

View menu

Layers menu

Tools menu

Window menu

Options menu

Using the Tree Area Control

Selecting / defining a database name

Selecting a family

Selecting a person

Database fields

Additional LDS information

SQL syntax

Supported GEDCOM syntax

Timeline text file format

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

GEDCOM

Layer

LDS

Metaphone

OLE embedding

OLE linking

OLE object

Soundex

Tree Area

How to get support

How to contact us

Ordering / registration

Tutorial - Working with person and family data forms

This tutorial requires the sample database supplied with the program - use File | Database | Open | Sample_V3

Subject: Using the controls on person and family data forms.

Family data

Find the family rectangle for F149 on the Tree Area and double-click on it. This opens the family data form for this family and it will look like this:

You can hover the mouse cursor on parts of the image of the data form above to find out what they're for.

Data fields:

This family has no "Marriage place". Let's enter it. Click on the "Marriage place" field (the one to the right of the "Marriage date" field) and type in "Clackmannan". As soon as you start typing the colour of the data form changes. This indicates that the data for this family has changed but has not been saved to the database yet. When you have finished typing click on the "Update" button to make the change permanent. The form colour will return to normal.

If you now place the mouse cursor over the "Divorce place" field and click the right mouse button, a small list will appear with only one entry, "Clackmannan". This is a "field pick list" which allows you to re-use field entries which you have made during the current Kith and Kin Pro session, without having to type them in again. Click on the "Clackmannan" entry in the pick list and "Clackmannan" will be placed in the "Divorce place" field. The data form has again changed to the "editing indicator" colour to show that the data has changed but not been saved. We didn't really want to make the change to the "Divorce place" field so click on the "Undo button to ignore the entry.

Notes:

Kith and Kin Pro allows you to enter more than one note for each person or family. Each note can have up to 30,000 characters and you can have as many notes as you wish. If you click on the "Next note" button you will see that this family has two notes, one called "Public notes" and the other called "Research notes". You can move backwards and forwards through the available notes by clicking on the "Previous note" and "Next note" buttons.

The note descriptions can be anything you like, they are simply there so that you know what each note is for. If you only ever use one note per family/person you can leave the "Description" fields blank.

As you scroll between the "Public notes" and the "Research notes" you will notice that the first has a "Privacy level" of "0" and the other has "1". The "Privacy level" field allows you to control whether to publish certain types of notes in reports, Web pages and GEDCOM files. Clearly the "Research notes" are for your own use and you wouldn't normally want to include them on your Web pages, for example. When exporting the Web pages you would therefore select a "Notes to level" value of "0" to include any notes which have a "Privacy level" of "0" but not any notes with "Privacy levels" greater than that.

The text for the notes can be entered into the notes text box in the data form, but for large notes it is easier to work with the note in the Notes Editor. Click on the "Edit notes" button to open the notes form for either of the two notes in this family. The Notes Editor works just like any Windows text editor. The Notes Editor has additional functions which let you import, export, print, search for and replace text. Click on the "Close" button to go back to the family data form.

Father/mother/children:

Although you can see the names of the people in this family, their data is not stored in the family record. Kith and Kin Pro stores a link to the person data record for each person. If you want to see the data for the father, mother or children you have to open up the person data form for the appropriate person.

Let's look at the details for the mother [P424] Helen SHARP. Place the mouse cursor over the "Mother" box and click the right mouse button. This pops-up a menu with options relating to the mother. Click on the "Edit" item to open the mother's person data form. You could also have just double-clicked on the "Mother" box. Click on the "Close" button to close the [P424] person data form and return to the [F149] family data form.

You can do the same to display the father's details. To display any of the children you must first click on the child you want to look at and then right-click to pop-up the menu or just double-click on the child's name.

Pictures:

You can store photographs and other images with family or person data records if you have a scanner or if the photos have been scanned into files for you.

Click on the "Pictures" button to open the pictures form. This form controls adding and maintaining pictures in the database. Each person or family can have as many images as you want. You can paste pictures from the clipboard, scan them directly from a scanner or import them from image files.

Family F149 has one old photo stored in the database. It has been given the description "All the women folk". You can see a "thumbnail" of the image on the pictures form. Thumbnails are small versions of the full-sized image which Kith and Kin Pro creates when you add the picture to the database. The full-sized image is stored as an image file separate from the database. Double-click on the thumbnail to view the full-sized image. When the full-sized image has opened you can right-click on it to access additional options relating to the full-sized image.

Click on the full-sized image to close it and go back to the pictures form. Click on the "Close" button to close the pictures form.

Notice that the "Pictures" button on the family data form is coloured. This indicates that picture(s) exist for this family. Family data forms which have no pictures have a "Pictures" button like this . Objects buttons, source buttons and alias buttons are also only coloured when items exist.

Press CTRL+L to close any open data forms.

Person data

Click on the "Edit person" button on the button bar and type "416" into the "Code" box at the bottom of the form. This opens the person data form for [P416] Robert GORDON and it will look like this:

You can hover the mouse cursor over parts of the image of the data form above to find out what they're for.

See "Data fields", "Notes", "Father/mother/children" and "Pictures" in "Family data" above. They work the same way in the person data form for data fields, notes, "Child of family" / "Marriages" and pictures.

Sources:

Kith and Kin Pro allows you to record the sources of information that you have discovered and whether you consider that information reliable.

Click on the "Death sources" button on the person data form. This button is coloured so we know that there is at least one source reference for this field. The source references form will open and you can see that there is a single source reference which relates to the death of P416.

Source details are recorded in three parts; (1) the source reference, (2) the source document and (3) the document repository. The source reference (1) holds the page number and quality of data and is a reference to a source document (2). The source document (2) holds the details of the physical source document; title, author, media, etc and also refer to a repository (3). The document repository (3) holds details of where documents are kept; name, address, etc.

The death date of P416 was confirmed by the statutory record of deaths held by the General Register Office Scotland.

This source has been recorded in the database by adding firstly a source reference which is just a pointer to the page in the book and the "Quality of data" (in this case "Primary evidence"). Secondly, a source document is added to record the details of the book itself, title, author, etc. Thirdly, a document repository is added to record the location of the source document.

You can make source references point to any document record already in the database without having to add the source document details every time you add a new source reference. The same is true for documents and repositories. This means that you will have individual repository records which are pointed to by many source documents and individual document records which are pointed to by many source references.

Click on the "Close" button to close the source references form.

Press CTRL+L to close any open data forms.

Next tutorial - Searching using queries

Download genealogy software with free 30-day trial. Free to try software is for genealogy and family history. Import GEDCOM files and print genealogy charts using our free to try family history program. Download our free to try family tree program. Free 30-day trial family history program. Historians can download genealogy database program which is free-to-try. Download genealogy program to store your family tree, there is a free trial. Download genealogy software. You can download free trial versions of our family tree software to store your family history. To store family history, download genealogy software. Download family history software which is free to try and is used for genealogy. Store your family tree in our genealogy software database. Store family trees using our free to try family tree program. Download genealogy program which is free to try. Download genealogy software for family history. Why not download genealogy software for your ancestors history. It's free for 30 days. We specialize in free to try genealogy software available for download. Here users can download family tree software for historians. Download genealogy software for family history research. Our database program is the best for family history research and tracing your ancestors.