Kith and Kin Pro manual

Kith and Kin Pro site SpanSoft main site

Kith and Kin Pro

Getting started

Introducing Kith and Kin Pro

Converting from older versions of Kith and Kin

Using Kith and KinPro with TreeDraw

Tutorials

Tutorial - Using the Tree Area

Tutorial - Working with person and family data forms

Tutorial - Simple searching

Tutorial - Searching using queries

Tutorial - Printing

Tutorial - Adding extra fields to people and families

Tutorial - Starting your own family tree

Tutorial - Importing a GEDCOM file

Tasks

Database maintenance

Starting a new database

Creating a clean database

Opening an existing database

Saving a database

Merging two databases

Copying a database

Copying part of a database

Changing the name of a database

Packing a database

Repairing a database

Clearing a database

Deleting a database

Adding and maintaining user-defined fields

Backing-up your data

Restoring data from a backup

Data maintenance

Adding a new family

Adding a new person

Editing an existing family

Editing an existing person

Marking probable links

Adding and maintaining aliases

Editing notes

Organising notes

Entering dates

Working with pictures

Working with objects

Adding and maintaining sources

Deleting a family

Deleting a person

Adding and maintaining source documents

Adding and maintaining source document repositories

Updating descriptions

Re-using an old person or family code

Updating death flags

Removing duplicate records

Editing data in bulk

Searching / querying

Searching for people

Seaching for families

Searching for sources

Using a query to find data

Calculating ages

Calculating phonetic codes

Displaying statistics

Displaying a relationship between two people

Searching for date errors / inconsistencies

Searching for events on a particular day

Searching for people who are not on the Tree Area

Displaying modified records

Screen

Moving around the Tree Area

Zooming in and out

Moving to a specific family

Selecting families using the mouse

Selecting families by relationship

Selecting all families

Moving families

Displaying a family summary

Arranging the open forms

Closing all open forms at once

Aligning families vertically

Using the Timeline Window

Choosing layers

Choosing the selection's layer

Choosing all layers

Moving families to a layer

Removing families from a layer

Creating a new layer from selection

Managing layers

Choosing fonts and colours

Turning the Tree Area on and off

Turning the Button Bar on and off

Turning the Status Bar on and off

Turning the Tree Area Control on and off

Printing

Using the report control form

Printing the tree layout

Printing family details

Printing person details

Printing indices

Printing a descendant tree

Printing an ancestral tree

Printing an indented descendant tree

Printing a missing data report

Printing a timeline

Printing a census report

Printing source document details

Printing document repository details

Setting printer options

Setting page options

Previewing a report on the screen

Printing from a preview

Printing to text files

Copying printed pages to the clipboard

Importing / exporting

Importing a GEDCOM file

Exporting a GEDCOM file

Exporting Web pages

Customising Web pages

Exporting data to a delimited text file

Importing a text file into notes

Exporting a text file from notes

Exporting a report to a PDF file

General

Setting preferences

Editing the timeline

Customising the button bar

Setting date options

Converting dates

Setting options

Setting current database options

Choosing a family to move to when the tree is opened

Choosing the current database language

Setting regional / language options

Setting picture options

Exiting from the program

Checking for program updates

Reference

File menu

Edit menu

Search menu

View menu

Layers menu

Tools menu

Window menu

Options menu

Using the Tree Area Control

Selecting / defining a database name

Selecting a family

Selecting a person

Database fields

Additional LDS information

SQL syntax

Supported GEDCOM syntax

Timeline text file format

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

GEDCOM

Layer

LDS

Metaphone

OLE embedding

OLE linking

OLE object

Soundex

Tree Area

How to get support

How to contact us

Ordering / registration

Using a query to find data

In the Search Window click on the SQL Query tab at the top.

Kith and Kin Pro implements SQL (Structured Query Language), a powerful, industry standard method for finding data. You can either use simple query criteria, which build a query statement for you, or enter the SQL query directly for more advanced queries.

SQL lets you choose which parts of the database you want to see and how you want to see it. This includes selecting tables and fields, renaming the field headings, selecting records based on conditional statements and sorting records.

Simple queries:

Select the database table which you want to search through. Each table contains the records for a different part of the database, eg. People or Documents. When you select a table all the available fields appear in the "Selected Fields" list and all the fields start off as selected.

Choose the fields which you want to appear in the query from the "Selected Fields" list. A field is selected if it has a "" symbol beside it. To select/deselect a field, double-click on it. You can use the Select all and Select none buttons to instantly select all or none of the fields in the "Selected Fields" list.

To specify conditions for the search, drag field names from the "Selected Fields" list and drop them into the "Field name" column of the "Criteria" grid. You can use any field, not just selected fields.

For each field in the "Criteria" grid, type in a comparison operator in the "Op" column and the value to search for in the "Search text" column. Valid comparison operators are:

=Equal to
<Less than
>Greater than
<=Less than or equal to
>=Greater than or equal to
<>Not equal to
#Empty
##Not empty

Criteria for text-type fields can be partial matches and/or case-sensitive.
For example, a partial match, not case-sensitive search for "Firstnames = fred" will find "Fred", "Frederick" and "Alfred" but with partial match turned off will only find "Fred".
If the same example was a partial match and case-sensitive then only "Firstnames = Fred" would find "Fred" and "Frederick".

If you want certain records excluded from the query, click in the "Exclude" column of the "Criteria" grid, on the appropriate row. A red block indicates that any records which match the condition for this row will not be included in the query. For example, "Surname <> " (excluded) will find all People records which have no surname entry.

Normally, queries with multiple conditions (more than one row in the "Criteria" grid) produce results where records meet every condition. You can change this so that the results contain records which meet any of the conditions by clicking on the Match any field option. Clicking on the Match all fields option only finds records which match all the conditions.

To remove all conditions from the "Criteria" grid click on the Clear button.

When the query criteria are complete, click on the Search button to perform the search.

Advanced queries:

You can create an SQL query directly in the SQL query edit box. This allows you to use additional SQL features such as sorting and using multiple tables.

For details and examples of SQL statements see SQL syntax.

When the SQL query statement is complete, click on the Search button to perform the search.

Using previous queries:

Kith and Kin Pro stores the last 20 queries which were applied. You can scroll through these old query statements by clicking on the Previous query and the Next query buttons.

To better keep track of which queries do what, you can add a Description to each of the previous queries. Simply type a description into the box provided.

When the query you want appears in the SQL query edit box, click on the Search button to perform the search. You can edit the query first if necessary.

You can delete an old query. First scroll through the queries to select the one you want to delete, then click on the Delete this query button.

Storing queries:

You can export the current SQL query as a text file by clicking on the Save to file button. The file can imported back into Kith and Kin Pro by clicking on the Load from file button.

Using the query results:

Once you have the displayed the results of your query you can format the way that the results are displayed. In the field-names row at the top of the grid, drag the right-hand edge of the column to change the size of the column. Drag in the centre of a field name in the top row of the grid to move the entire column to a different position.

You can open the record's data form directly by double-clicking on its row in the results table.

You can also output your query results; either as a delimited text file, printout or print preview. Right-click on the results to see the output options.

For simpler searches select one of the Person, Family or Source tabs at the top of the Search Form.

See also

Download genealogy software with free 30-day trial. Free to try software is for genealogy and family history. Import GEDCOM files and print genealogy charts using our free to try family history program. Download our free to try family tree program. Free 30-day trial family history program. Historians can download genealogy database program which is free-to-try. Download genealogy program to store your family tree, there is a free trial. Download genealogy software. You can download free trial versions of our family tree software to store your family history. To store family history, download genealogy software. Download family history software which is free to try and is used for genealogy. Store your family tree in our genealogy software database. Store family trees using our free to try family tree program. Download genealogy program which is free to try. Download genealogy software for family history. Why not download genealogy software for your ancestors history. It's free for 30 days. We specialize in free to try genealogy software available for download. Here users can download family tree software for historians. Download genealogy software for family history research. Our database program is the best for family history research and tracing your ancestors.