Kith and Kin Pro manual

Kith and Kin Pro site SpanSoft main site

Kith and Kin Pro

Getting started

Introducing Kith and Kin Pro

Converting from older versions of Kith and Kin

Using Kith and KinPro with TreeDraw

Tutorials

Tutorial - Using the Tree Area

Tutorial - Working with person and family data forms

Tutorial - Simple searching

Tutorial - Searching using queries

Tutorial - Printing

Tutorial - Adding extra fields to people and families

Tutorial - Starting your own family tree

Tutorial - Importing a GEDCOM file

Tasks

Database maintenance

Starting a new database

Creating a clean database

Opening an existing database

Saving a database

Merging two databases

Copying a database

Copying part of a database

Changing the name of a database

Packing a database

Repairing a database

Clearing a database

Deleting a database

Adding and maintaining user-defined fields

Backing-up your data

Restoring data from a backup

Data maintenance

Adding a new family

Adding a new person

Editing an existing family

Editing an existing person

Marking probable links

Adding and maintaining aliases

Editing notes

Organising notes

Entering dates

Working with pictures

Working with objects

Adding and maintaining sources

Deleting a family

Deleting a person

Adding and maintaining source documents

Adding and maintaining source document repositories

Updating descriptions

Re-using an old person or family code

Updating death flags

Removing duplicate records

Editing data in bulk

Searching / querying

Searching for people

Seaching for families

Searching for sources

Using a query to find data

Calculating ages

Calculating phonetic codes

Displaying statistics

Displaying a relationship between two people

Searching for date errors / inconsistencies

Searching for events on a particular day

Searching for people who are not on the Tree Area

Displaying modified records

Screen

Moving around the Tree Area

Zooming in and out

Moving to a specific family

Selecting families using the mouse

Selecting families by relationship

Selecting all families

Moving families

Displaying a family summary

Arranging the open forms

Closing all open forms at once

Aligning families vertically

Using the Timeline Window

Choosing layers

Choosing the selection's layer

Choosing all layers

Moving families to a layer

Removing families from a layer

Creating a new layer from selection

Managing layers

Choosing fonts and colours

Turning the Tree Area on and off

Turning the Button Bar on and off

Turning the Status Bar on and off

Turning the Tree Area Control on and off

Printing

Using the report control form

Printing the tree layout

Printing family details

Printing person details

Printing indices

Printing a descendant tree

Printing an ancestral tree

Printing an indented descendant tree

Printing a missing data report

Printing a timeline

Printing a census report

Printing source document details

Printing document repository details

Setting printer options

Setting page options

Previewing a report on the screen

Printing from a preview

Printing to text files

Copying printed pages to the clipboard

Importing / exporting

Importing a GEDCOM file

Exporting a GEDCOM file

Exporting Web pages

Customising Web pages

Exporting data to a delimited text file

Importing a text file into notes

Exporting a text file from notes

Exporting a report to a PDF file

General

Setting preferences

Editing the timeline

Customising the button bar

Setting date options

Converting dates

Setting options

Setting current database options

Choosing a family to move to when the tree is opened

Choosing the current database language

Setting regional / language options

Setting picture options

Exiting from the program

Checking for program updates

Reference

File menu

Edit menu

Search menu

View menu

Layers menu

Tools menu

Window menu

Options menu

Using the Tree Area Control

Selecting / defining a database name

Selecting a family

Selecting a person

Database fields

Additional LDS information

SQL syntax

Supported GEDCOM syntax

Timeline text file format

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

GEDCOM

Layer

LDS

Metaphone

OLE embedding

OLE linking

OLE object

Soundex

Tree Area

How to get support

How to contact us

Ordering / registration

Working with objects

Kith and Kin Pro can store multimedia OLE objects associated with a particular person or family. The objects are intended to be used for multimedia such as videos, sounds, etc which cannot be printed.

The Objects form displays a list of the objects currently associated with this person or family at the top of the form. Click on a description of the object in the list and the object will appear as an icon.

When you make any changes to the data, the data form will become highlighted using the "Dialog editing indicator" colour. This indicates that the data is currently being edited and has not yet been saved to the database. Click on the Accept edit button to save the new data to the database, or the Cancel edit button to cancel any changes made.

Adding a new object:

First click on the Add new object button to create a new record to store the object in.

Enter a Description of the object.

To add an object to the record, see "Acquiring an object" below.

Click on the OK button to save the object to the database.

Editing an existing object:

To edit the data for an existing object or to change the object, first select the object you want to change in the list at the top of the data form. The current data and object will appear in the boxes below the list. Modify the data and/or object and/or acquire a new object (see below) and click on the Accept edit button.

Deleting an object:

Delete an object by selecting the required object in the list at the top of the data form and then clicking on the Delete button.

Acquiring an object:

Pasting an object from the clipboard:

If you have copied an object from another program onto the clipboard, paste it into the current record by clicking on the Paste button or using Paste in the thumbnail pop-up menu. Pasting the object in this way embeds the object in the database. If you want to link the object use Paste special in the pop-up menu.

Inserting a new object:

Use Insert from the pop-up menu. This gives you several options to define the way the object is stored and displayed.

Playing an object:

Select the required object in the list at the top of the data form and then double-click on the object or on its description in the list to play it. Playing is usually the default action of a multi-media object but some objects may have different default actions.

To see a list of the actions available, right-click on the object to display the pop-up menu.

Sorting the objects:

You can move the objects around in the list to get the order you want, simply by dragging entries up and down the list with the left mouse button. When you start to drag an entry, a black line will appear indicating where the object will be placed. Release the mouse button when the line is in the position you want.

Download genealogy software with free 30-day trial. Free to try software is for genealogy and family history. Import GEDCOM files and print genealogy charts using our free to try family history program. Download our free to try family tree program. Free 30-day trial family history program. Historians can download genealogy database program which is free-to-try. Download genealogy program to store your family tree, there is a free trial. Download genealogy software. You can download free trial versions of our family tree software to store your family history. To store family history, download genealogy software. Download family history software which is free to try and is used for genealogy. Store your family tree in our genealogy software database. Store family trees using our free to try family tree program. Download genealogy program which is free to try. Download genealogy software for family history. Why not download genealogy software for your ancestors history. It's free for 30 days. We specialize in free to try genealogy software available for download. Here users can download family tree software for historians. Download genealogy software for family history research. Our database program is the best for family history research and tracing your ancestors.