Kith and Kin Pro manual

Kith and Kin Pro site SpanSoft main site

Kith and Kin Pro

Getting started

Introducing Kith and Kin Pro

Converting from older versions of Kith and Kin

Using Kith and KinPro with TreeDraw

Tutorials

Tutorial - Using the Tree Area

Tutorial - Working with person and family data forms

Tutorial - Simple searching

Tutorial - Searching using queries

Tutorial - Printing

Tutorial - Adding extra fields to people and families

Tutorial - Starting your own family tree

Tutorial - Importing a GEDCOM file

Tasks

Database maintenance

Starting a new database

Creating a clean database

Opening an existing database

Saving a database

Merging two databases

Copying a database

Copying part of a database

Changing the name of a database

Packing a database

Repairing a database

Clearing a database

Deleting a database

Adding and maintaining user-defined fields

Backing-up your data

Restoring data from a backup

Data maintenance

Adding a new family

Adding a new person

Editing an existing family

Editing an existing person

Marking probable links

Adding and maintaining aliases

Editing notes

Organising notes

Entering dates

Working with pictures

Working with objects

Adding and maintaining sources

Deleting a family

Deleting a person

Adding and maintaining source documents

Adding and maintaining source document repositories

Updating descriptions

Re-using an old person or family code

Updating death flags

Removing duplicate records

Editing data in bulk

Searching / querying

Searching for people

Seaching for families

Searching for sources

Using a query to find data

Calculating ages

Calculating phonetic codes

Displaying statistics

Displaying a relationship between two people

Searching for date errors / inconsistencies

Searching for events on a particular day

Searching for people who are not on the Tree Area

Displaying modified records

Screen

Moving around the Tree Area

Zooming in and out

Moving to a specific family

Selecting families using the mouse

Selecting families by relationship

Selecting all families

Moving families

Displaying a family summary

Arranging the open forms

Closing all open forms at once

Aligning families vertically

Using the Timeline Window

Choosing layers

Choosing the selection's layer

Choosing all layers

Moving families to a layer

Removing families from a layer

Creating a new layer from selection

Managing layers

Choosing fonts and colours

Turning the Tree Area on and off

Turning the Button Bar on and off

Turning the Status Bar on and off

Turning the Tree Area Control on and off

Printing

Using the report control form

Printing the tree layout

Printing family details

Printing person details

Printing indices

Printing a descendant tree

Printing an ancestral tree

Printing an indented descendant tree

Printing a missing data report

Printing a timeline

Printing a census report

Printing source document details

Printing document repository details

Setting printer options

Setting page options

Previewing a report on the screen

Printing from a preview

Printing to text files

Copying printed pages to the clipboard

Importing / exporting

Importing a GEDCOM file

Exporting a GEDCOM file

Exporting Web pages

Customising Web pages

Exporting data to a delimited text file

Importing a text file into notes

Exporting a text file from notes

Exporting a report to a PDF file

General

Setting preferences

Editing the timeline

Customising the button bar

Setting date options

Converting dates

Setting options

Setting current database options

Choosing a family to move to when the tree is opened

Choosing the current database language

Setting regional / language options

Setting picture options

Exiting from the program

Checking for program updates

Reference

File menu

Edit menu

Search menu

View menu

Layers menu

Tools menu

Window menu

Options menu

Using the Tree Area Control

Selecting / defining a database name

Selecting a family

Selecting a person

Database fields

Additional LDS information

SQL syntax

Supported GEDCOM syntax

Timeline text file format

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

GEDCOM

Layer

LDS

Metaphone

OLE embedding

OLE linking

OLE object

Soundex

Tree Area

How to get support

How to contact us

Ordering / registration

Tutorial - Adding extra fields to people and families

This tutorial requires the sample database supplied with the program - use "File | Database | Open | Sample_V3"

Subject: Adding a user-defined field.

As well as storing data in the standard person and family fields (eg. Surname, Marriage date, etc) you can add your own "user-defined" fields to the database. GEDCOM supports some additional fields which you may want to add to your database, although you can give them your own name. The name you use for the field is used as the description in printouts. The sample family tree contains two extra fields, "Occupation" and "Cause of death". Person [P423]'s "Occupation" field contains the entry "Coal weigher". This would appear in a Details report as "Occupation: Coal weigher".

You don't have to use one of the standard GEDCOM fields as a user-defined field; you can add any field you want and if it doesn't have an equivalent GEDCOM tag then it won't be included in GEDCOM transfers.

Let's say we want to record a graduation date and place for people in the family tree. We need to add two new fields to the "People" table of the database. We'll call one "Date of graduation" and the other "Graduation place".

Use "Options" in the main menu, then "User fields" and then "Person". This opens a data form titled "User defined Person fields" and you will see that in the "User fields" list there is already an "Occupation" field. Click on the "Field name" box and type in "Date of graduation". Now click on the down arrow to the right of the "Field type" box to bring down the list of available field types.

There are several different field types which you can use for a user-defined field:

For a more comprehensive description of the field types, see: Adding and maintaining user-defined fields.

We want to make "Date of graduation" a date field so select "Date" from the "Field type" list. We want this new field to be included in GEDCOM transfers and there happens to be a suitable tag for it so scroll through the entries in the "GEDCOM tag" list until you reach "GRAD = Graduation". Click on the small "+" to the left of "GRAD" to display the tags available within GRAD. We want the date so click on "DATE = Date" and the tags "INDI GRAD DATE" will appear in the box above the GEDCOM tag list (INDI is just the GEDCOM tag for individual, ie. person, and it is displayed here so that you can tell it is not a family tag, which would start with FAM).

The remaining option for a user-defined field is "Privacy level". This can be used to exclude certain fields from report, Web pages, etc, later on. For example, you might have added extra fields which only store data related to your research; giving them a privacy level of 1 will exclude them from reports where you choose only to print fields at level 0. For our graduation date field we want that to appear everywhere so we will leave the Privacy level at 0 (blank).

That's all the information we need to create this new field. Click on the "Add" button to add the new field to the database. When Kith and Kin Pro has finished you will see the new field in the "User fields" box.

If you now click on "Date of graduation" in the "User fields" box the other boxes on the form will show the current settings for the field.

Add the "Graduation place" field in the same way. Change "Field name" to "Graduation place", "Field type" to "String" and "GEDCOM tag" to GRAD | PLAC. You will notice that the "Add" button has not been enabled yet. This is because there is one more setting we need to make for a string type field and that is the "String size". Type "60" into the "String size" box and click on the "Add" button to add the field to the database.

Click on the "Close" button to close the user-defined fields form. Now click on the "Edit person" button on the button bar and select any person from the list. You can see that the new fields have been added to the list above the "Notes" section of the person data form.

Notice that there is only one source button for all the user-defined fields. To add a source reference for a user-defined field you must first make sure that you have selected the correct field in the list. Placing the mouse cursor over the sources button will tell you which user-defined field is currently selected.

Next tutorial - Starting your own family tree

Download genealogy software with free 30-day trial. Free to try software is for genealogy and family history. Import GEDCOM files and print genealogy charts using our free to try family history program. Download our free to try family tree program. Free 30-day trial family history program. Historians can download genealogy database program which is free-to-try. Download genealogy program to store your family tree, there is a free trial. Download genealogy software. You can download free trial versions of our family tree software to store your family history. To store family history, download genealogy software. Download family history software which is free to try and is used for genealogy. Store your family tree in our genealogy software database. Store family trees using our free to try family tree program. Download genealogy program which is free to try. Download genealogy software for family history. Why not download genealogy software for your ancestors history. It's free for 30 days. We specialize in free to try genealogy software available for download. Here users can download family tree software for historians. Download genealogy software for family history research. Our database program is the best for family history research and tracing your ancestors.