Kith and Kin Pro manual

Kith and Kin Pro site SpanSoft main site

Kith and Kin Pro

Getting started

Introducing Kith and Kin Pro

Converting from older versions of Kith and Kin

Using Kith and KinPro with TreeDraw

Tutorials

Tutorial - Using the Tree Area

Tutorial - Working with person and family data forms

Tutorial - Simple searching

Tutorial - Searching using queries

Tutorial - Printing

Tutorial - Adding extra fields to people and families

Tutorial - Starting your own family tree

Tutorial - Importing a GEDCOM file

Tasks

Database maintenance

Starting a new database

Creating a clean database

Opening an existing database

Saving a database

Merging two databases

Copying a database

Copying part of a database

Changing the name of a database

Packing a database

Repairing a database

Clearing a database

Deleting a database

Adding and maintaining user-defined fields

Backing-up your data

Restoring data from a backup

Data maintenance

Adding a new family

Adding a new person

Editing an existing family

Editing an existing person

Marking probable links

Adding and maintaining aliases

Editing notes

Organising notes

Entering dates

Working with pictures

Working with objects

Adding and maintaining sources

Deleting a family

Deleting a person

Adding and maintaining source documents

Adding and maintaining source document repositories

Updating descriptions

Re-using an old person or family code

Updating death flags

Removing duplicate records

Editing data in bulk

Searching / querying

Searching for people

Seaching for families

Searching for sources

Using a query to find data

Calculating ages

Calculating phonetic codes

Displaying statistics

Displaying a relationship between two people

Searching for date errors / inconsistencies

Searching for events on a particular day

Searching for people who are not on the Tree Area

Displaying modified records

Screen

Moving around the Tree Area

Zooming in and out

Moving to a specific family

Selecting families using the mouse

Selecting families by relationship

Selecting all families

Moving families

Displaying a family summary

Arranging the open forms

Closing all open forms at once

Aligning families vertically

Using the Timeline Window

Choosing layers

Choosing the selection's layer

Choosing all layers

Moving families to a layer

Removing families from a layer

Creating a new layer from selection

Managing layers

Choosing fonts and colours

Turning the Tree Area on and off

Turning the Button Bar on and off

Turning the Status Bar on and off

Turning the Tree Area Control on and off

Printing

Using the report control form

Printing the tree layout

Printing family details

Printing person details

Printing indices

Printing a descendant tree

Printing an ancestral tree

Printing an indented descendant tree

Printing a missing data report

Printing a timeline

Printing a census report

Printing source document details

Printing document repository details

Setting printer options

Setting page options

Previewing a report on the screen

Printing from a preview

Printing to text files

Copying printed pages to the clipboard

Importing / exporting

Importing a GEDCOM file

Exporting a GEDCOM file

Exporting Web pages

Customising Web pages

Exporting data to a delimited text file

Importing a text file into notes

Exporting a text file from notes

Exporting a report to a PDF file

General

Setting preferences

Editing the timeline

Customising the button bar

Setting date options

Converting dates

Setting options

Setting current database options

Choosing a family to move to when the tree is opened

Choosing the current database language

Setting regional / language options

Setting picture options

Exiting from the program

Checking for program updates

Reference

File menu

Edit menu

Search menu

View menu

Layers menu

Tools menu

Window menu

Options menu

Using the Tree Area Control

Selecting / defining a database name

Selecting a family

Selecting a person

Database fields

Additional LDS information

SQL syntax

Supported GEDCOM syntax

Timeline text file format

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

GEDCOM

Layer

LDS

Metaphone

OLE embedding

OLE linking

OLE object

Soundex

Tree Area

How to get support

How to contact us

Ordering / registration

Tutorial - Searching using queries

This tutorial requires the sample database supplied with the program - use "File | Database | Open | Sample_V3"

Subject: Using SQL search criteria.

Kith and Kin Pro implements SQL (Structured Query Language), a powerful, industry standard method for finding data. You can either use simple query criteria, which build a query statement for you, or enter the SQL query directly for more advanced queries.

In this tutorial we will concentrate on doing some simple queries. For advanced SQL queries see: Using a query to find data. For even simpler searching see the previous tutorial "Simple searching".

SQL lets you choose which parts of the database you want to see and how you want to see it. This includes selecting tables and fields, renaming the field headings, selecting records based on conditional statements and sorting records.

Click on the "Search" button on the button bar to open the search window.

You can hover the mouse cursor over parts of the image of the search window above to find out what they're for.

The search window in the image above has been set to find all the people with "gordon" in their surnames. Let's see how that was done.

First, click on the "Clear criteria" button to make sure that there is nothing in the query criteria. Also, make sure that "Partial match", "Case sensitive" and "Match all fields" options are set as shown.

Click on the down arrow to the right of the "Database table" box to bring down the list of tables and select "People". Each type of record in Kith and Kin Pro has its own database table, all the tables together make up the whole database. To perform a query, you select the table which you want to search through and only records from that table are included in the results.

The "Selected fields" list will now show all the available fields in the "People" table. Notice that they all have a "" symbol beside them indicating that every field will appear in the results list. We only want the "Description" field to be included in the results, so we need to remove the ""s from the rest of the fields. Double-click on "Code" in the "Selected fields" list to remove the "" and do the same for "Surname". We could go through the rest of the fields doing this, but for speed, clear all the selections at once by clicking on the "Select none" button . Now all the ""s have been removed so double-click on "Description" to re-selected it.

You may have noticed that each time you changed a selection in the "Selected fields" list, the text in SQL query box changed. It should now have two lines of SQL statements "SELECT People.[Description]" and "FROM People". As you choose the settings for your search criteria, Kith and Kin Pro automatically builds the SQL query for you. For advanced queries you will be able to enter the SQL statements directly.

We have now told the program which table to get the records from and which fields from that table to include in the results list. Next we have to give it some conditions to search for.

Place the mouse cursor over the "Surname" field in the "Selected fields" list and hold down the left mouse button. Now drag the cursor over to the top row of the "Field name" column in the "Criteria" grid. When you're there, release the mouse button and "Surname" will appear in the top-left corner of the grid. You could also have just typed "Surname" into the grid box. Click on the box in the "Op" (operator) column to the right, then click the drop-down button and select "=" from the drop-down list. Click on the box in the "Search text" column to the right again (or just press the TAB key) and type in "gordon" (without the quotes).

That's our query complete. Click on the "Search" button to perform the search. The results list will now show the 38 records of people whose surname is Gordon.

Now let's narrow the search down a bit and look for all the "James GORDON"s.

Go back to the "Selected fields" list and drag the "Firstnames" field into the second row of the "Field name" column of the "Criteria" grid. Type "=" into the "Op" column and "james" into the "Search text" column so that the "Criteria" grid looks like this:

Now click on the "Search" button again and only 4 records will appear.

This search was performed with the "Match all fields" option selected. This meant that Kith and Kin Pro only found records which matched both of the criteria, ie. only people who had "gordon" in their surnames and "james" in their firstnames. Click on the "Match any field" option and click on the "Search" button again. 43 records are found this time, all the people who have "gordon" in their surnames or "james" in their firstnames.

Once you have records in the results list, you can do things with them. Double-clicking on a record opens its data form for editing. Right-clicking on the results list pops up a menu which allows you to print or preview the results list or export the records to a delimited text file.

A delimited text file is useful for exporting data from Kith and Kin Pro to other applications such as a database or spreadsheet program. Once the data is in a database, for instance, you can produce customised list reports.

You can change the width of the columns in the results list by dragging the right edge of the column in the top row (where the column names are) left or right. You can also change the order of the columns by dragging the middle of the column in the top row left or right.

Click on the "Close" button to close the search window.

Next tutorial - Printing

Download family history software with free 30-day trial. Our free to try software is for family history research and family trees. We specialize in free to try genealogy program available for download. Here users can download genealogy program for historians. Download genealogy software for family history. Why not download genealogy software for your ancestors history? It's free for 30 days. Free 30-day trial family history software. Users can download genealogy database program which is free-to-try. Download genealogy program to store your family tree, there is a free trial. Download genealogy software. You can download free trial versions of our genealogy program to store your family history. To store family history, download genealogy software. Import GEDCOM files and print family tree charts using our free to try genealogy software. Download our free to try program for researching your ancestors. Download family history software which is free to try and is used for ancestry research. Store your family tree in our genealogy software database. Store family trees using our free to try database program. Download family history program which is free to try. Download genealogy software for family history research. Our family history program is good for family history research.