Kith and Kin Pro manual

Kith and Kin Pro site SpanSoft main site

Kith and Kin Pro

Getting started

Introducing Kith and Kin Pro

Converting from older versions of Kith and Kin

Using Kith and KinPro with TreeDraw

Tutorials

Tutorial - Using the Tree Area

Tutorial - Working with person and family data forms

Tutorial - Simple searching

Tutorial - Searching using queries

Tutorial - Printing

Tutorial - Adding extra fields to people and families

Tutorial - Starting your own family tree

Tutorial - Importing a GEDCOM file

Tasks

Database maintenance

Starting a new database

Creating a clean database

Opening an existing database

Saving a database

Merging two databases

Copying a database

Copying part of a database

Changing the name of a database

Packing a database

Repairing a database

Clearing a database

Deleting a database

Adding and maintaining user-defined fields

Backing-up your data

Restoring data from a backup

Data maintenance

Adding a new family

Adding a new person

Editing an existing family

Editing an existing person

Marking probable links

Adding and maintaining aliases

Editing notes

Organising notes

Entering dates

Working with pictures

Working with objects

Adding and maintaining sources

Deleting a family

Deleting a person

Adding and maintaining source documents

Adding and maintaining source document repositories

Updating descriptions

Re-using an old person or family code

Updating death flags

Removing duplicate records

Editing data in bulk

Searching / querying

Searching for people

Seaching for families

Searching for sources

Using a query to find data

Calculating ages

Calculating phonetic codes

Displaying statistics

Displaying a relationship between two people

Searching for date errors / inconsistencies

Searching for events on a particular day

Searching for people who are not on the Tree Area

Displaying modified records

Screen

Moving around the Tree Area

Zooming in and out

Moving to a specific family

Selecting families using the mouse

Selecting families by relationship

Selecting all families

Moving families

Displaying a family summary

Arranging the open forms

Closing all open forms at once

Aligning families vertically

Using the Timeline Window

Choosing layers

Choosing the selection's layer

Choosing all layers

Moving families to a layer

Removing families from a layer

Creating a new layer from selection

Managing layers

Choosing fonts and colours

Turning the Tree Area on and off

Turning the Button Bar on and off

Turning the Status Bar on and off

Turning the Tree Area Control on and off

Printing

Using the report control form

Printing the tree layout

Printing family details

Printing person details

Printing indices

Printing a descendant tree

Printing an ancestral tree

Printing an indented descendant tree

Printing a missing data report

Printing a timeline

Printing a census report

Printing source document details

Printing document repository details

Setting printer options

Setting page options

Previewing a report on the screen

Printing from a preview

Printing to text files

Copying printed pages to the clipboard

Importing / exporting

Importing a GEDCOM file

Exporting a GEDCOM file

Exporting Web pages

Customising Web pages

Exporting data to a delimited text file

Importing a text file into notes

Exporting a text file from notes

Exporting a report to a PDF file

General

Setting preferences

Editing the timeline

Customising the button bar

Setting date options

Converting dates

Setting options

Setting current database options

Choosing a family to move to when the tree is opened

Choosing the current database language

Setting regional / language options

Setting picture options

Exiting from the program

Checking for program updates

Reference

File menu

Edit menu

Search menu

View menu

Layers menu

Tools menu

Window menu

Options menu

Using the Tree Area Control

Selecting / defining a database name

Selecting a family

Selecting a person

Database fields

Additional LDS information

SQL syntax

Supported GEDCOM syntax

Timeline text file format

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

GEDCOM

Layer

LDS

Metaphone

OLE embedding

OLE linking

OLE object

Soundex

Tree Area

How to get support

How to contact us

Ordering / registration

Tutorial - Using the Tree Area

This tutorial requires the sample database supplied with the program - use "File | Database | Open | Sample_V3"

Subjects: Moving around the tree, zooming in and out, selecting families, moving families, displaying a family summary, displaying the timeline.

The Kith and Kin Pro main screen consists of a caption where the name of the current family tree is displayed, a main menu, a button bar, a status bar and the Tree Area. You can hover the mouse cursor over parts of the image of the screen above to find out what they're for.

The Tree Area

Below the button bar is the Tree Area which displays each family as a rectangle like this:
  (colours may vary depending on your screen setup)
You can see that this family has the code F149 and consists of a father with the surname HUNTER and a mother with the surname SHARP. There are also 8 children along the bottom; 3 boys and 5 girls.

Let's find this family on the screen. If you can't see this family rectangle, it may be because the Tree Area is turned off. If the "Layers" menu is disabled then the Tree Area has been turned off. Turn on the Tree Area by using "View | Tree Area" in the main menu. Now click on the "Go to family" button on the button bar. If the button bar is not visible then click on "View" in the main menu and then click on the "Button bar" item. When you have clicked on the "Go to family" button you will see the family selection list. We know that we want to go to family F149 so type "149" into the "Code" box at the bottom of the form and then click on the OK button or press RETURN. You will now see the family rectangle for family F149 in the centre of the Tree Area.

Relationships between families are shown on the Tree Area by link lines. You can see that family F149 has a link line connecting the father to F166, one connecting the mother to F169 and the third child to F118. The father appears as a child in family F166 and both linked person icons represent the same person.

You can find out more about family F149 by displaying its family summary. Move the mouse cursor over the F149 family rectangle and click the right mouse button. A window appears with details of all the people in family F149. If you right-click on another family rectangle then the original summary will be replaced with the new summary. To get the summary window to close, click either mouse button anywhere on the Tree Area where there is no family rectangle.

Navigating the Tree Area

Note: If you get lost in the Tree Area during this exercise, use "Search" and then "Go to start family" in the main menu.

You can scroll around the Tree Area by holding down the right mouse button and dragging. Make sure that the mouse cursor is not over a family rectangle or you will get a family summary instead.

You can zoom in and out of the Tree Area display either by using the scroll wheel on your mouse or the zoom buttons on the button bar. If you want to quickly reset the zoom to 100% and center the Tree Area on the mouse cursor at the same time, click the center mouse button (this may be the mouse wheel).

Let's go back to family F149. Use the "Go to family" button as you did before. Now place the mouse cursor over the family rectangle for F149 and click the left mouse button. The family rectangle becomes highlighted (changes colour) and may now look like this:

This indicates that the family has been selected. It is useful to do this before zooming in or out because it keeps the Tree Area centred on the selected family.

Now click on the "Zoom out" button on the button bar. You can now see more of the tree and the rectangles have been scaled down. You can keep clicking on the "Zoom out" button or scrolling the mouse wheel to zoom further and further out.

Return to normal scale by clicking on the "Normal view" button

Alternatively you can use the Tree Area Control to navigate the Tree Area.

Selecting families

In "Navigating the Tree Area" we selected a single family but you can also select several families at once. Having a selection of families highlighted is used by Kith and Kin Pro for several functions, including moving families, copying part of the tree, exporting data and printing reports.

As before, select family F149 by moving the mouse cursor over the family rectangle and clicking the left mouse button. Now do the same with family F169 but this time hold down the SHIFT key as you click the mouse. Now both F149 and F169 are selected. You can carry on adding more families to the selection in this way.

Clear the current selection by clicking the left mouse button when the cursor is anywhere in the Tree Area where there is no family rectangle. All the family rectangle colours will return to normal.

You can quickly select a large block of families by dragging a marquee around them. Position the mouse cursor just above family F167 like this:

and hold down the left mouse button. Now drag the mouse (still holding down the left button) down and to the right until you see an expanding dotted rectangle which covers all the family rectangles from F166 to F171 and F149 like this:

Now release the mouse button and all the families within the marquee will be selected. You can combine this function with the SHIFT key to add families to the current selection.

You can also use "Edit" then "Select all" in the main menu to select all the families in the tree, or press the CTRL+A keys to do the same thing.

There is one more way that you can select families and that is by using relationships. Clear the current selection and use "Edit" then "Select families" then "Descendants" in the main menu. The cursor will change to Place the cursor over family F171 and click the left mouse button. Family F171 and all the families which are descended from F171 are now highlighted. You can do the same for ancestors of a family and for a direct line between two families.

You can open a family's data form directly by double-clicking on its family rectangle. We will look at data forms and editing data in the next tutorial.

Moving families

Naturally, to format the tree layout to the way you want it, you need to move the family rectangles around the Tree Area.

Clear the current selection and move the Tree Area so that you can see family F149. Click on the F149 family but continue to hold the left mouse button down. Now move the mouse and you will drag a dotted outline of the family rectangle. Move the outline so that it is just to the right of F149 and release the mouse button. F149 will move to the new position and its link lines will adjust accordingly.

Do the same again. Drag F149 to the right until the outline is up against the right-hand edge of the Tree Area. The Tree Area will start to scroll automatically. Hold down the CTRL key whilst the Tree Area is scrolling and it will start to scroll faster. Release the mouse button to drop F149.

You will probably be well to the right of the family tree by now. With F149 still selected, zoom out using the Tree Area Control until you can see the rest of the family rectangles. You can use all the Tree Area functions even when zoomed out, so drag F149 back to its original position and click on the "Normal view" button. Notice how the Tree Area always had F149 in view because it was selected.

Using the timeline

The Timeline Window shows chronologically sorted dates from two sources. It shows all dates from all the currently selected families and dates from all the people associated with those families, ie. parents and children. The window can also show historical events taken from the current timeline for the same period.

Press the CTRL+A keys to select all the families and then click on the "Timeline" button on the button bar. The Timeline Window will open showing all the dates in the family tree plus the dates from the timeline file.

Move the Timeline Window so that you can see part of the Tree Area underneath and click anywhere on the Tree Area where there is no family rectangle to clear the current selection. All the events in the Timeline Window will disappear because there are no selected families to display events from. Click on any of the family rectangles in the Tree Area and the events from that family only will appear in the Timeline Window (plus the appropriate historical events).

You can use the events in the Timeline Window to open a person's or family's data form directly by double-clicking on an event. We will look at data forms and editing data in the next tutorial. Click on the "Timeline" button again to close the Timeline Window.

Next tutorial - Working with person and family data forms

Download genealogy software with free 30-day trial. Free to try software is for genealogy and family history. Import GEDCOM files and print genealogy charts using our free to try family history program. Download our free to try family tree program. Free 30-day trial family history program. Historians can download genealogy database program which is free-to-try. Download genealogy program to store your family tree, there is a free trial. Download genealogy software. You can download free trial versions of our family tree software to store your family history. To store family history, download genealogy software. Download family history software which is free to try and is used for genealogy. Store your family tree in our genealogy software database. Store family trees using our free to try family tree program. Download genealogy program which is free to try. Download genealogy software for family history. Why not download genealogy software for your ancestors history. It's free for 30 days. We specialize in free to try genealogy software available for download. Here users can download family tree software for historians. Download genealogy software for family history research. Our database program is the best for family history research and tracing your ancestors.